From: 张胜举 <zhangshen...@cmss.chinamobile.com> Date: Mon, 5 Jun 2017 09:10:22 +0800
>> -----Original Message----- >> From: David Miller [mailto:da...@davemloft.net] >> Sent: Monday, June 05, 2017 4:13 AM >> To: pshe...@ovn.org >> Cc: zhangshen...@cmss.chinamobile.com; pshe...@nicira.com; >> netdev@vger.kernel.org >> Subject: Re: [net-next] openvswitch: add macro >> MODULE_ALIAS_VPORT_TYPE for vport type alias >> >> From: Pravin Shelar <pshe...@ovn.org> >> Date: Sat, 3 Jun 2017 22:58:22 -0700 >> >> > On Sat, Jun 3, 2017 at 6:47 AM, Zhang Shengju >> > <zhangshen...@cmss.chinamobile.com> wrote: >> >> Add a new macro MODULE_ALIAS_VPORT_TYPE to unify and simplify the >> >> declaration of vport type alias, and replace magic numbers with >> >> symbolic constants. >> >> >> >> Signed-off-by: Zhang Shengju <zhangshen...@cmss.chinamobile.com> >> >> --- >> >> net/openvswitch/vport-geneve.c | 2 +- >> >> net/openvswitch/vport-gre.c | 2 +- >> >> net/openvswitch/vport-vxlan.c | 2 +- >> >> net/openvswitch/vport.h | 3 +++ >> >> 4 files changed, 6 insertions(+), 3 deletions(-) >> >> >> >> diff --git a/net/openvswitch/vport-geneve.c >> >> b/net/openvswitch/vport-geneve.c index 5aaf3ba..1c068d6 100644 >> >> --- a/net/openvswitch/vport-geneve.c >> >> +++ b/net/openvswitch/vport-geneve.c >> >> @@ -141,4 +141,4 @@ static void __exit ovs_geneve_tnl_exit(void) >> >> >> >> MODULE_DESCRIPTION("OVS: Geneve switching port"); >> >> MODULE_LICENSE("GPL"); -MODULE_ALIAS("vport-type-5"); >> >> +MODULE_ALIAS_VPORT_TYPE(OVS_VPORT_TYPE_GENEVE); >> >> diff --git a/net/openvswitch/vport-gre.c >> >> b/net/openvswitch/vport-gre.c index 0e72d95..48a5852 100644 >> >> --- a/net/openvswitch/vport-gre.c >> >> +++ b/net/openvswitch/vport-gre.c >> >> @@ -113,4 +113,4 @@ static void __exit ovs_gre_tnl_exit(void) >> >> >> >> MODULE_DESCRIPTION("OVS: GRE switching port"); >> >> MODULE_LICENSE("GPL"); -MODULE_ALIAS("vport-type-3"); >> >> +MODULE_ALIAS_VPORT_TYPE(OVS_VPORT_TYPE_GRE); >> > >> > This is user visible change. For example this is changing the gre >> > module alias from "vport-type-3" to "vport-type-OVS_VPORT_TYPE_GRE". >> > This could break userspace application. >> >> Agreed, you really can't do this. > > Hi David, > Actually this change does not change module alias name. I use '__stringify' > to > address this. Please refer my previous reply. Yep, I saw that, I waive my objection :-)