On 5/19/17 10:16 PM, yuan linyu wrote: > @@ -240,13 +240,15 @@ struct ndisc_options *ndisc_parse_options(const struct > net_device *dev, > "%s: duplicated ND6 option found: > type=%d\n", > __func__, nd_opt->nd_opt_type); > } else { > - ndopts->nd_opt_array[nd_opt->nd_opt_type] = > nd_opt; > + ndopts->nd_opt_array[nd_opt->nd_opt_type] = > + nd_opt; > } > break; > case ND_OPT_PREFIX_INFO: > ndopts->nd_opts_pi_end = nd_opt; > if (!ndopts->nd_opt_array[nd_opt->nd_opt_type]) > - ndopts->nd_opt_array[nd_opt->nd_opt_type] = > nd_opt; > + ndopts->nd_opt_array[nd_opt->nd_opt_type] = > + nd_opt; > break; > #ifdef CONFIG_IPV6_ROUTE_INFO > case ND_OPT_ROUTE_INFO:
This makes the code less readable. Readability needs to trump rigid 80-column coding style. > @@ -512,7 +513,8 @@ void ndisc_send_na(struct net_device *dev, const struct > in6_addr *daddr, > in6_ifa_put(ifp); > } else { > if (ipv6_dev_get_saddr(dev_net(dev), dev, daddr, > - > inet6_sk(dev_net(dev)->ipv6.ndisc_sk)->srcprefs, > + inet6_sk(dev_net(dev)->ipv6.ndisc_sk)-> > + srcprefs, again here I did not finish out this really long patch, but in general the 80-column rule can not be applied so rigidly.