On Mon, 2017-02-13 at 10:57 -0800, Shannon Nelson wrote: > The use of gotos for handling the incoming events made this code > harder to read and support than it should be. This patch straightens > out and clears up the logic. > > Signed-off-by: Shannon Nelson <shannon.nel...@oracle.com> > --- > drivers/net/ethernet/sun/sunvnet_common.c | 94 > ++++++++++++++--------------- > 1 files changed, 45 insertions(+), 49 deletions(-) > > diff --git a/drivers/net/ethernet/sun/sunvnet_common.c > b/drivers/net/ethernet/sun/sunvnet_common.c [] > @@ -738,41 +738,37 @@ static int vnet_event_napi(struct vnet_port *port, int > budget) [] > + /* we don't expect any other bits */ > + BUG_ON(port->rx_event & ~(LDC_EVENT_DATA_READY | > + LDC_EVENT_RESET | > + LDC_EVENT_UP));
Is it really necessary to use BUG_ON here?