On Sat, 2017-02-04 at 13:44 -0800, Stephen Hemminger wrote: > On Sat, 4 Feb 2017 10:20:36 -0800 > Eric Dumazet <eduma...@google.com> wrote: > > > > > -static int skge_poll(struct napi_struct *napi, int to_do) > > +static int skge_poll(struct napi_struct *napi, int budget) > > Ok, but renaming parameter is not really necessary.
About all drivers use @budget for this parameter. By having the same variable names, it is easier to compare various implementations and spot common errors. > > > - if (work_done < to_do) { > > + if ((work_done < budget) && napi_complete_done(napi, work_done)) { > > unsigned long flags; > > Parenthesis around work_done < budget are unnecessary. Yes, thanks you, I will do this in all the patches for V2.