On Mon, Aug 08, 2016 at 05:28:39PM +0200, Jiri Benc wrote: > On Mon, 8 Aug 2016 17:17:17 +0200, Simon Horman wrote: > > +bool skb_mac_header_present(struct sk_buff *skb) > > +{ > > + return skb->dev->type == ARPHRD_ETHER || > > + (skb->dev->type == ARPHRD_NONE && > > + skb->protocol == htons(ETH_P_TEB)); > > +} > > +EXPORT_SYMBOL(skb_mac_header_present); > > I'd suggest a different name, this looks like it has something to do > with skb->mac_header, which it doesn't. skb_eth_header_present, perhaps?
I struggled to come up with a reasonable name and I do like your suggestion better than mine. I'll update the code as you suggest unless a better name emerges.