On Fri, Apr 15, 2016 at 02:25:46PM -0400, Vivien Didelot wrote: > Add a new switch info structure which will be later extended to store > switch models static information, such as product number, name, number > of ports, number of databases, etc. > > Merge the lookup function in the probing code, so that we avoid multiple > checking of the MII bus, as well a multiple ID reading. > > Signed-off-by: Vivien Didelot <vivien.dide...@savoirfairelinux.com> > --- > drivers/net/dsa/mv88e6123.c | 8 +++--- > drivers/net/dsa/mv88e6131.c | 10 +++---- > drivers/net/dsa/mv88e6171.c | 10 +++---- > drivers/net/dsa/mv88e6352.c | 14 +++++----- > drivers/net/dsa/mv88e6xxx.c | 67 > +++++++++++++++++++-------------------------- > drivers/net/dsa/mv88e6xxx.h | 14 ++++++---- > 6 files changed, 58 insertions(+), 65 deletions(-) > > diff --git a/drivers/net/dsa/mv88e6123.c b/drivers/net/dsa/mv88e6123.c > index 00c1121..02bf16c 100644 > --- a/drivers/net/dsa/mv88e6123.c > +++ b/drivers/net/dsa/mv88e6123.c > @@ -17,10 +17,10 @@ > #include <net/dsa.h> > #include "mv88e6xxx.h" > > -static const struct mv88e6xxx_switch_id mv88e6123_table[] = { > - { PORT_SWITCH_ID_6123, "Marvell 88E6123" }, > - { PORT_SWITCH_ID_6161, "Marvell 88E6161" }, > - { PORT_SWITCH_ID_6165, "Marvell 88E6165" }, > +static const struct mv88e6xxx_info mv88e6123_table[] = { > + { MV88E6XXX_INFO(0x121, "Marvell 88E6123") }, > + { MV88E6XXX_INFO(0x161, "Marvell 88E6161") }, > + { MV88E6XXX_INFO(0x165, "Marvell 88E6165") },
Why replace PORT_SWITCH_ID_6123 with the magic number 0x121? Andrew