On Wed, Apr 6, 2016 at 1:57 AM, David Laight <david.lai...@aculab.com> wrote: > From: Petri Gynther >> Sent: 05 April 2016 01:10 > ... >> 2. Readability: Add parentheses around nr_frags + 1. > ... >> - if (ring->free_bds <= nr_frags + 1) { > ... >> + if (ring->free_bds <= (nr_frags + 1)) { > > The extra () are not needed and do not improve readability. > > David >
Not needed from C language point of view, but I personally like it better that way. Also, making it consistent with these: bcmgenet.c:1227: if (ring->free_bds > (MAX_SKB_FRAGS + 1)) { bcmgenet.c:1523: if (ring->free_bds <= (MAX_SKB_FRAGS + 1))