On Sat, 2006-25-03 at 15:11 +0530, Balbir Singh wrote: > > Thanks for the advice, I will dive into nesting. I could not find any > in tree users who use nesting, so I have a few questions >
Hrm - I have to say i am suprised theres nothing; i could have sworn Thomas had done some conversions already. > nla_nest_start() accepts two parameters an skb and an attribute type. > Do I have to create a new attribute type like TASKSTATS_TYPE_AGGR to > contain the nested attributes > > TASKSTATS_TYPE_AGGR > TASKSTATS_TYPE_PID/TGID > TASKSTATS_TYPE_STATS > > > but this will lead to > > TASKSTATS_TYPE_AGGR > TASKSTATS_TYPE_PID > TASKSTATS_TYPE_STATS > TASKSTATS_TYPE_AGGR > TASKSTATS_TYPE_TGID > TASKSTATS_TYPE_STATS > > being returned from taskstats_exit_pid(). > no this is wrong by virtue of having TASKSTATS_TYPE_AGGR twice. Again invoke the rule i cited earlier. What you could do instead is a second AGGR; and your nesting would be: TASKSTATS_TYPE_AGGR1 <--- nest start with this type TASKSTATS_TYPE_PID <-- NLA_U32_PUT TASKSTATS_TYPE_STATS <-- NAL_PUT_TYPE <-- nest end of TASKSTATS_TYPE_AGGR1 TASKSTATS_TYPE_AGGR2 <--- nest start with this type TASKSTATS_TYPE_TGID <-- NLA_U32_PUT TASKSTATS_TYPE_STATS <-- NAL_PUT_TYPE <-- nest end of TASKSTATS_TYPE_AGGR2 > The other option is to nest > > TASKSTATS_TYPE_PID/TGID > TASKSTATS_TYPE_STATS > The advantage being you dont introduce another T. > but the problem with this approach is, nla_len contains the length of > all attributes including the nested attribute. So it is hard to find > the offset of TASKSTATS_TYPE_STATS in the buffer. > So you would distinguish the two as have something like: TASKSTATS_TYPE_PID u32 pid TASKSTATS_TYPE_STATS TASKSTATS_TYPE_TGID u32 tgid TASKSTATS_TYPE_STATS or TASKSTATS_TYPE_PID u32 pid TASKSTATS_TYPE_TGID u32 tgid both should be fine. The difference between the two is the length in the second case will be 4 and in the other case will be larger. But come to think of it, this will introduce unneeded semantics; you have very few items to do, so forget it. Go with scheme #1 but change the names to TASKSTATS_TYPE_AGGR_PID and TASKSTATS_TYPE_AGGR_TGID. cheers, jamal - To unsubscribe from this list: send the line "unsubscribe netdev" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html