On Tue, Sep 06, 2005 at 12:21:05PM +0400, Alexey Dobriyan wrote: > * usual s/u32/__be32/. > * add svc_getnl(): > Take network-endian value from buffer, convert to host-endian > one and return it. > * add svc_putnl(): > Take host-endian value, convert to network-endian one and put > it into a buffer. > * convert to svc_getnl(), svc_putnl().
ACK, but since we have it inlined anyway I would suggest switching most of remaining svc_putu32() to svc_putnl(). Stuff like svc_putu32(xdr_one) can become svc_putnl(1) and cc will handle that just fine. I'm still not too happy about the names, though - almost to the point where I'd seriously consider something like svc_encode_u32()/svc_decode_u32(). At least that would be more in line with the rest of XDR-related marshalling code... Dunno. If Trond ACKs that, I'll take this as-is and add the conversion mentioned above as a separate patch on top of that. It would be great if somebody came up with better names... - To unsubscribe from this list: send the line "unsubscribe netdev" in the body of a message to [EMAIL PROTECTED] More majordomo info at http://vger.kernel.org/majordomo-info.html