On Sat, 27 Aug 2005 12:25:43 +0200, Pavel Machek wrote:
> > Sequence number is stored in bits 4 to 15 of the Sequence Control field
> > in 802.11 header. Lower 4 bits are used for fragment number.
> 
> Comment would be nice.

Added.

> What other changes are required in userspace after your patches are
> applied?

AFAIK none.

> > I agree. Don't know who started to use ieee80211_ prefixes but I think
> > there wasn't better prefix available (p80211 is the name of another -
> > although dead - project, wlan is confusing, etc.). We try to use as
> > short names as possible - do you have any idea how to shorten this
> > one?
> 
> BRIDGE_TUNEL_P :-). Okay WIFI is trademark-encumbered. [Do trademarks
> even apply in this context?]

Hm. And shouldn't we use "i71" prefix (like i18n or l10n)? ;-D

> I think inline function is going to be more readable than above.

Ok, converted. And IEEE80211_SNAP_IS_* renamed to snap_is_* and moved to
ieee80211_rx.c as it is not needed outside of that file anyway.

> > It is a static table for converting of internally used rate constants (enum
> > ieee80211_rate) to (and from) values used in 802.11 management frames.
> > It is exported as drivers for some devices with more advanced firmware
> > need to convert the values themselves.
> 
> Comment in the source code would be nice.

Added.

> > +static inline int _iwe_stream_add_event(struct translate_scan *data,
> > +                                        struct iw_event *iwe, int len)
> > [...]
> > 
> > Now this is strange. _foo that is wrapper around foo. Looks too
> > similar to __foo convention to my eyes. Is some better naming
> > possible?

Renamed to iwe_stream_try_add_event().


-- 
Jiri Benc
SUSE Labs
-
To unsubscribe from this list: send the line "unsubscribe netdev" in
the body of a message to [EMAIL PROTECTED]
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to