On Tue, 9 Mar 2021 12:32:38 GMT, Chris Hegarty <che...@openjdk.org> wrote:
>> Hi, >> >> Could someone please review my code for updating the code in the `java.net` >> and `java.nio` packages to make use of the `instanceof` pattern variable? >> >> Kind regards, >> Patrick > > src/java.base/share/classes/java/net/InterfaceAddress.java line 107: > >> 105: >> 106: if (Objects.equals(address, cmp.address) && >> 107: Objects.equals(broadcast, cmp.broadcast) && > > This could be simplified to: > > public boolean equals(Object obj) { > if (obj instanceof InterfaceAddress cmp > && Objects.equals(address, cmp.address) > && Objects.equals(broadcast, cmp.broadcast) > && maskLength == cmp.maskLength) { > return true; > } > return false; > } or go one step further and replace the if statement just with the boolean expression. ------------- PR: https://git.openjdk.java.net/jdk/pull/2890