The returns section of the java.net.URLClassLoader.findResources(String)
method documentation, contains the following sentence:
   "an Enumeration of URLs If the loader is closed, the Enumeration
    will be empty."
should be replaced by:
   "An Enumeration of URLs. If the loader is closed, the Enumeration
    will be empty."

diff --git a/src/java.base/share/classes/java/net/URLClassLoader.java b/src/java.base/share/classes/java/net/URLClassLoader.java
--- a/src/java.base/share/classes/java/net/URLClassLoader.java
+++ b/src/java.base/share/classes/java/net/URLClassLoader.java
@@ -658,7 +658,7 @@
      *
      * @param name the resource name
      * @exception IOException if an I/O exception occurs
-     * @return an {@code Enumeration} of {@code URL}s
+     * @return An {@code Enumeration} of {@code URL}s.
      *         If the loader is closed, the Enumeration will be empty.
      */
     public Enumeration<URL> findResources(final String name)

-Chris.

Reply via email to