On 14/05/2013 12:54, Michael McMahon wrote:
I have updated the webrev for this at:
http://cr.openjdk.java.net/~michaelm/8010464/webrev.2/
I took a pass over the updated webrev and it mostly looks good to me.
In HttpURLConnection then I wonder if it would be better if
getInputStream, getOutputStream and followRedirect set the connecting
flag rather than URLtoSocketPermission. The side effect on the protocol
handler state is a bit surprising in this method. Alternatively then
maybe the method needs a better name.
On MessageHeader then getHeaderNamesInList could use
java.util.StringJoiner to avoid rolling your own.
Are you planning to add @bug to the tests?
I wonder if about dependency on SimpleSSLContext in the test as I don't
think that test was originally intended to be a "test library".
-Alan.