Hello List, I have recently released a fesh, new, and probably bugged module on CPAN called TripleStore, because, err, that's what it is. Basically it's an interface to manipulate triple stores (insert, delete, update) and also to perform queries with a syntax inspired from the 'RDBF' style syntax, i.e.
# rdbf-style syntax # select ( ?x ?y ) from triple where (?x worksFor ?y) (?y name 'BBC') # Equivalent TripleStore syntax my $x = $::DB->var(); my $y = $::DB->var(); my $res = $::DB->select ( $x, $y, $::DB->clause ($x, 'worksFor', $y) & $::DB->clause ($x, 'name', 'BBC') ); I am looking forward to maybe rename this module, because I think that TripleStore is too generic... I've previously been moaning about generic namespaces being taken by modules on this list so I would like to avoid making this mistake :) Another thing to note is that this TripleStore module has __NOTHING__ to do with RDF, you might be able to use it in conjunction with an RDF parser to store RDF but that's where it stops. Any ideas for an appropriate name? Thanks in advance, -- Building a better web - http://www.mkdoc.com/ --------------------------------------------- Jean-Michel Hiver [EMAIL PROTECTED] - +44 (0)114 255 8097 Homepage: http://www.webmatrix.net/