Hi,

If it is a pragma, I tend to think it should be named a as a pragma, especially when
it works with input/output. Then perhaps it should be named IO::ANSI::Win32 or
similar ?

Arthur

On onsdag, nov 6, 2002, at 16:21 Europe/Stockholm, Jean-Louis MOREL wrote:

At 08:47 05/11/2002 +0100, you wrote:
Perhaps Win32::Console::ANSI would be a better name?

Arthur
What embarrasses me with a name like Win32::Console::ANSI, it's
that one can think that ANSI is an extension of Win32::Console.
But this module doesn't add any functionality, no method, to
Win32::Console. It uses Win32::Console behind the scene; the user
doesn't have access to an Win32::Console-object or method.
It's because Win32::ANSIConsole doesn't have an interface :-)
It works like a pragma.
The user adds "use Win32::ANSIConsole;" in the beginning of his
script and that's all!
This 'pseudo-pragma' overloads the 'print' function  to permit
the interpretation of the escape-codes. It's transparent for the user.
In my opinion, it is more natural to write:
  use Win32::ANSIConsole;
  use Term::ANSIColor;
  ...etc
or
  use Win32::ANSIConsole;
  use Term::ANSIScreen;
  ...etc

Of course, it's only my opinion; it's subjective :-)

--
J-L.M.




Reply via email to