Hey all- I just recently finished rewriting an application used to modify host records. In the process, I wrote it into a completely modular form, with much reusable code. I'd like to upload this stuff to CPAN. There are several modules, but they can actually be used separately or together. So, I'd like your advice on naming. The application is called "HostEdit", and currently it lives under "Net::HostEdit" (seems appropriate). It is an OO module that creates network, subnet, and host objects, and lets you modify their properties. It's completely transactional, allowing multiple concurrent users access to your hosts files. When you're all done you call ->commit() to write your changes to disk. In addition, in the process I created two other modules, one for terminal user interaction ("Term::UI" - should it be "Term::CLI"?) and one for Apache-style configuration parsing. This latter module just lives under "Net::HostEdit::Conf" right now, but considering it works 100% on Apache config files (and I had promised mod_perl something like this a while ago :-), I was thinking of naming it "Apache::ConfigFile", which was the name Doug MacEachern originally proposed for it. In any case, what do you think? Judging by the above there would be three module listings: Name DSLIP Description ------------- ----- -------------------------------------------- Net::HostEdit RdpOp Comprehensive host maintenance system Term::UI Rdpfp Simple, flexible terminal user interface Apache::ConfigFile Rdpfp Read an Apache-style configuration file Along with probably a "Bundle::HostEdit" to make it easy to use (it needs Unix::Login and some other stuff). Input? Thanks as always, Nate