OK -- now who makes the final decision?
Seems like renaming an already-uploaded module could cause confusion.
-c
At 8:29 PM -0400 7/28/00, Joshua N Pritikin wrote:
>On Fri, Jul 28, 2000 at 02:01:13PM -0700, [EMAIL PROTECTED] wrote:
>> I feel dumb for not having found that one in CPAN before writing mine :-).
>
>Oops :-)
>
>> Yes, I think mine could maybe be a replacement, BUT it doesn't do the
>> one feature that yours does: namely, reload based on file-changed-time.
>
>Hm hm.
>
>> That's an optimization that's probably missing from mine, but I
>> intentionally didn't add that because some modules have load-time side
>> effects (such as BEGIN blocks) and so forcing an unconditional reload is
>> slightly different from reloading only changed files.
>
>Agreed.
>
>> In light of that, maybe mine should be a different module, maybe called:
>>
>> Module::Reload::Force
>
>Or maybe I should rename mine to Module::Autoreload?
>
>> .... but one of the biggest aspects of mine is its ability to do
>> nothing during end-user runtime, but kick in selectively at Development
>> time -- i.e. it doesn't always force the Reload. That's why I thought
>> Devel:: might be the best place for it.
>
>do_stuff() if $ENV{TESTING}; # pretty trival
>
>> I think naming is very important and I
>> do want to come up with the best name.
>
>Oh good. Me too.
>
>--
>Never ascribe to malice that which can be explained by stupidity.
> (via, but not speaking for Deutsche Bank)
------------------------------------------------------------------------
Chris Thorman (413) 473-0853 e-fax
------------------------------------------------------------------------