Hi there, I've come up with a module which handles installing files to a PalmPilot handheld with the minimum of hassle on both UNIX and Windows. Currently the name I'm using for this module is PDA::PilotInstall . I didn't want to pollute the PDA::Pilot namespace as that's already owned by the pilot-link stuff. How does this sound? BTW it's not quite ready for release just yet, I just wanted to ensure the namespace was OK before I get writing READMEs etc. --j.