The defining characteristic from the users point of view is the use of C<local> so that should be in the name. Similarly OnExit is central. And Scope:: has precedent as the namespace. So:
Scope::LocalOnExit Suggestions: - I'd capitalize $OnExit: local $OnExit = sub { ... }; or allow the name to be chosen by what the use imports. - If the code ref throws an exception I'd like it propagated. Tim. On Wed, Mar 31, 2010 at 02:59:23AM -0400, David Nicol wrote: > local_onExit is how it is now > http://davidnicol.diaryland.com/onExit.html > The semantics should be exactly the same as Scope::OnExit, but the > syntax is somewhat convoluted, abusing the C<local> mechanism as it > does. > > Scope::OnExit::PurePerl would seem to imply the same syntax, which > would be misleading. > > > -- > question doubt >