I have a Cisco router I am trying to replace.  I will describe the Cisco
box, the replacement OpenBSD router, the setup and finally what issues I
am having.  The bgpd.conf contents are at the bottom of the email.  If
there is some additional information that would be useful, please let me
know.

The old Cisco router (CiscoRTR01) is a 3640 with 128 megs of memory.  It
has 4 T1's out to the internet, 2 from Sprint (AS1239) and 2 from AT&T
(AS7018).  Each pair of lines has a BGP session associated with it.
However, it needs replacing because it is too slow to deal with the
number of pps as well as handle all of the BGP sessions. In addition, I
have to do major filtering of the BGP feeds because of memory limits. 

There is also a second router (RTR05), this one running OpenBSD and
OpenBGPd and working very well.  This router has 4 T1's as well, but
they are all from Frontier Communications (AS7011) so there is only a
single BGP session here.  

The two routers also have an iBGP session between them.

Both OpenBSD routers are as close to identical hardware as I could get
them.  Both are Dell PowerEdge 2450's with 512M ram, dual 733s, 2
Sangoma A102u cards and an additional dual port fxp card as well as the
on board fxp.  Both are running OpenBSD 3.8-stable.  Currently with
GENERIC kernal, not GENERIC-MP although I get the same issues with
GENERIC-MP.

The new OpenBSD router (RTR01) is supposed to be a drop in replacement
for the Cisco box.

As it is now, everything seems to work except the Cisco box is straining
to keep up.  When I swap in the OpenBSD box, everything appears to come
up, all the T1's come up (although one of the Sprint lines takes quite a
while) and all 3 bgp sessions come up (and get in sync amazingly faster
than the Cisco box).  

However, all routes show up as 'Incomplete' with a ? at the end of
bgpctl s rib:
RTR01 $ bgpctl s rib 199.104.207.8 all
flags: * = Valid, > = Selected, I = via IBGP, A = Announced
origin: i = IGP, e = EGP, ? = Incomplete

flags destination         gateway          lpref   med aspath origin
*>    199.104.207.0/24    66.185.224.3       100    29 1239 5650 5650 7011 ?
*     199.104.207.0/24    66.185.224.3       100     0 7018 5650 5650 7011 ?

66.185.224.3 is the default gateway on RTR01.  If I just do 'bgpctl s
rib', looking through, I did not see any routes that did not have a '?'
at the end.  I didn't grep for that while the box was up though so I am
not sure that there weren't some.

On RTR05, while this new router is not plugged in, I get what I would
expect:
RTR05 $ bgpctl s rib 199.104.207.8 all
flags: * = Valid, > = Selected, I = via IBGP, A = Announced
origin: i = IGP, e = EGP, ? = Incomplete

flags destination         gateway          lpref   med aspath origin
*>    199.104.128.0/17    216.190.36.145     100     0 7011 5650 6461 26978 
2900 i

But once the new RTR01 is plugged in, I get this on RTR05 (and I can no
longer get to the Internet):
RTR05 $ bgpctl s rib 199.104.207.8 all
flags: * = Valid, > = Selected, I = via IBGP, A = Announced
origin: i = IGP, e = EGP, ? = Incomplete

flags destination         gateway          lpref   med aspath origin
I*>   199.104.207.0/24    216.190.36.145     100    29 1239 5650 5650 7011 ?


AS5650 is also Frontier, but the second AS on any of the AS paths out of
RTR05.

When RTR01 is plugged in, but RTR05 is not, I get the same issues with
the default gateway being chosen and the '?' indicating Incomplete.
However I don't have output from 'bgpctl s rib 199.104.207.8' all when
that is happening, so I do not remember what the aspath is.

On the new RTR01 all of the sessions come up and I get lots of prefixes:
$ bgpctl s
Neighbor             AS    MsgRcvd    MsgSent    OutQ  Up/Down
State/PrefixRcvd
AS 7018 AT&T          7018      33342         15     0 00:05:39 175331
AS 1239 Sprint        1239      33232         11     0 00:04:17 176981
AS 22429 rrlhcrtr050 22429      34629      56030     0 00:06:45  13144

It seems that I should get more routes from RTR05 but I could be wrong.

BGP seems to work well on RTR05 as well:
$ bgpctl s
Neighbor             AS    MsgRcvd    MsgSent    OutQ  Up/Down
State/PrefixRcvd
AS 7011 Frontier (EL  7011      55893       1924     0 15:57:53 177772
AS 22429 rrlhcrtr100 22429     104162     120304     0 00:00:46 174008

My problem appears to be an issue with the routes recieved on RTR01
being marked as 'Incomplete' but I am not sure how to figure out why
that would be.  

RTR01 bgpd.conf:
#macros
rrlhcrtr0500=66.185.224.9

# global configuration
AS 22429
router-id 66.185.224.1
network 66.185.224.0/20

# neighbors and peers
group "peering AS22429" {
        set weight      50
        remote-as       22429
        local-address   66.185.224.1
        neighbor $rrlhcrtr0500 {
                descr           "AS 22429 rrlhcrtr0500"
        }
}

neighbor 144.228.242.172 {
        remote-as       1239
        descr           "AS 1239 Sprint"
        local-address   66.185.239.55
        multihop        3
}

neighbor 12.123.145.122 {
        remote-as       7018
        descr           "AS 7018 AT&T"
        local-address   12.123.145.122
        multihop        3
}

# filter out prefixes longer than 24 or shorter than 8 bits
deny from any
allow from any prefixlen 8 - 24

# do not accept a default route
deny from any prefix 0.0.0.0/0

# filter bogus networks
deny from any prefix 10.0.0.0/8 prefixlen >= 8
deny from any prefix 172.16.0.0/12 prefixlen >= 12
deny from any prefix 192.168.0.0/16 prefixlen >= 16
deny from any prefix 169.254.0.0/16 prefixlen >= 16
deny from any prefix 192.0.2.0/24 prefixlen >= 24
deny from any prefix 224.0.0.0/4 prefixlen >= 4
deny from any prefix 240.0.0.0/4 prefixlen >= 4

and a very similar RTR05 bgpd.conf:

#macros
rrlhcrtr1001=66.185.224.1

# global configuration
AS 22429
router-id 66.185.224.9
network 66.185.224.0/20

# neighbors and peers
group "peering AS22429" {
        set weight      50
        remote-as       22429
        local-address   66.185.224.9
        neighbor $rrlhcrtr1001 {
                descr           "AS 22429 rrlhcrtr1001"
        }
}

neighbor 207.173.230.131 {
        remote-as       7011
        descr           "AS 7011 Frontier (ELI)"
        local-address   66.185.239.57
        multihop        2
        tcp md5sig password XXX
}

# filter out prefixes longer than 24 or shorter than 8 bits
deny from any
allow from any prefixlen 8 - 24

# do not accept a default route
deny from any prefix 0.0.0.0/0

# filter bogus networks
deny from any prefix 10.0.0.0/8 prefixlen >= 8
deny from any prefix 172.16.0.0/12 prefixlen >= 12
deny from any prefix 192.168.0.0/16 prefixlen >= 16
deny from any prefix 169.254.0.0/16 prefixlen >= 16
deny from any prefix 192.0.2.0/24 prefixlen >= 24
deny from any prefix 224.0.0.0/4 prefixlen >= 4
deny from any prefix 240.0.0.0/4 prefixlen >= 4


RTR01 - /etc/hostname.fxp0
inet 66.185.224.1 255.255.255.224 NONE
!route add -net 66.185.224.0/20  66.185.224.3
!route add -net 66.185.228.0/23  66.185.224.4

RTR01 - /etc/hostname.fxp1
description "Link to local WAN router"
inet 66.185.239.42 255.255.255.252
group wan

!route add -net 66.185.232.0/23  66.185.239.41
!route add -net 66.185.234.0/24  66.185.239.41
!route add -net 66.185.236.0/24  66.185.239.41
!route add -net 66.185.237.0/24  66.185.239.41
!route add -net 66.185.238.0/24  66.185.239.41
!route add -net 66.185.239.44/30 66.185.239.41
!route add -net 66.185.239.48/30 66.185.239.41
!route add -net 66.185.239.52/30 66.185.239.41

RTR01 - /etc/hostname.san0
description "T1 to Sprint line 1
inet 144.228.193.62 255.255.255.252 NONE
dest 144.228.193.61
group sprint
!route add -mpath 144.228.242.172 144.228.193.61 255.255.255.255

RTR01 - /etc/hostname.san1
description "T1 to Sprint line 2
inet 144.228.193.74 255.255.255.252 NONE
dest 144.228.193.73
group sprint
!route add -mpath 144.228.242.172 144.228.193.73 255.255.255.255

RTR01 - /etc/hostname.san2
description "T1 to AT&T line 1
media t1 mediaopt ppp
inet 12.124.16.22 255.255.255.252 
dest 12.124.16.21
group att
!route add -mpath 12.123.145.122 12.124.16.21

# These are for AT&T's monitoring system
!route add -mpath 135.89.154.144/28 12.124.16.21
!route add -mpath 135.89.152.48/28  12.124.16.21

RTR01 - /etc/hostname.san3
description "T1 to AT&T line 2
media t1 mediaopt ppp
inet 12.124.17.122 255.255.255.252
dest 12.124.17.121
group att
!route add -mpath 12.123.145.122 12.124.17.121

# These are for AT&T's monitoring system
!route add -mpath 135.89.154.144/28 12.124.17.121
!route add -mpath 135.89.152.48/28  12.124.17.121

RTR01 - /etc/hostname.lo1
description "Interface for BGP with Sprint (AS1239)"
inet 66.185.239.55 255.255.255.255 NONE
group sprint

RTR01 - /etc/hostname.lo2
description "Interface for BGP with AT&T (AS7018)"
inet 12.105.248.57 255.255.255.255
group att 


RTR05 - /etc/hostname.fxp0
inet 66.185.224.9 255.255.255.224 NONE
#inet 66.185.225.203 255.255.255.0 NONE
!route add -net 66.185.224.0 66.185.224.3 255.255.240.0

RTR05 - /etc/hostname.san0
description "Link 1 to Frontier
inet 216.190.36.134 255.255.255.252 NONE
dest 216.190.36.133
group czn

RTR05 - /etc/hostname.san1
description "Link 2 to Frontier
inet 216.190.36.138 255.255.255.252 NONE
dest 216.190.36.137
group czn

RTR05 - /etc/hostname.san2
description "Link 3 to Frontier
inet 216.190.36.142 255.255.255.252 NONE
dest 216.190.36.141
group czn

RTR05 - /etc/hostname.san3
description "Link 4 to Frontier
inet 216.190.36.146 255.255.255.252 NONE
dest 216.190.36.145
group czn

RTR05 - /etc/hostname.lo1
description "Loopback for BGP with Frontier (AS7011)"
inet 66.185.239.57 255.255.255.255 NONE


CiscoRTR01 config:

!
! Last configuration change at 18:42:42 UTC Thu Feb 9 2006
! NVRAM config last updated at 18:43:28 UTC Thu Feb 9 2006
!
version 12.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname RRLHCRTR1001
!
enable secret XXX
enable password XXX
!
ip subnet-zero
!
!
ip cef
ip name-server 66.185.224.15
ip name-server 66.185.224.16
!
!
!
!
!
interface Loopback0
 description Interface for load balancing on Sprint Lines
 ip address 66.185.239.55 255.255.255.255
!
interface Loopback1
 description Interface for load balancing on AT&T Lines
 ip address 12.105.248.57 255.255.255.255
!
interface FastEthernet0/0
 description Local Ethernet Interface
 ip address 66.185.224.1 255.255.255.224
 no ip mroute-cache
 duplex auto
 speed auto
!
interface Serial0/0
 description T1 to Sprint line 1
 ip address 144.228.193.62 255.255.255.252
 ip access-group 102 in
 ip access-group 100 out
 ip load-sharing per-packet
 ip route-cache flow
 no ip mroute-cache
 no fair-queue
!
interface FastEthernet0/1
 description Link to local WAN router
 ip address 66.185.239.42 255.255.255.252
 speed 100
 full-duplex
!
interface Serial0/1
 description T1 to Sprint line 2
 ip address 144.228.193.74 255.255.255.252
 ip access-group 102 in
 ip access-group 100 out
 ip load-sharing per-packet
 ip route-cache flow
 no ip mroute-cache
 no fair-queue
!
interface Ethernet1/0
 no ip address
 no ip mroute-cache
 shutdown
 half-duplex
!
interface Serial1/0
 description T1 to AT&T line 1
 ip address 12.124.16.22 255.255.255.252
 ip access-group 102 in
 ip access-group 100 out
 ip load-sharing per-packet
 encapsulation ppp
 ip route-cache flow
 no ip mroute-cache
!
interface Serial1/1
 description T1 to AT&T line 2
 ip address 12.124.17.122 255.255.255.252
 ip access-group 102 in
 ip access-group 100 out
 ip load-sharing per-packet
 encapsulation ppp
 ip route-cache flow
 no ip mroute-cache
!
interface Serial2/0
 no ip address
 shutdown
 fair-queue
!
interface Serial2/1
 no ip address
 shutdown
 fair-queue
!
router eigrp 22429
 auto-summary
!
router bgp 22429
 no synchronization
 bgp log-neighbor-changes
 network 66.185.224.0 mask 255.255.240.0
 aggregate-address 66.185.224.0 255.255.240.0 summary-only
 redistribute connected
 redistribute static
 neighbor 12.123.145.122 remote-as 7018
 neighbor 12.123.145.122 ebgp-multihop 3
 neighbor 12.123.145.122 update-source Loopback1
 neighbor 12.123.145.122 version 4
 neighbor 12.123.145.122 prefix-list No-Default-IN in
 neighbor 12.123.145.122 route-map at&t-IN in
 neighbor 12.123.145.122 route-map OUT out
 neighbor 12.123.145.122 filter-list 21 in
 neighbor 12.123.145.122 filter-list 10 out
 neighbor 66.185.224.9 remote-as 22429
 neighbor 66.185.224.9 version 4
 neighbor 66.185.224.9 prefix-list No-Default-IN in
 neighbor 66.185.224.9 route-map CZN-IN in
 neighbor 66.185.224.9 filter-list 22 in
 neighbor 144.228.242.172 remote-as 1239
 neighbor 144.228.242.172 ebgp-multihop 3
 neighbor 144.228.242.172 update-source Loopback0
 neighbor 144.228.242.172 version 4
 neighbor 144.228.242.172 prefix-list No-Default-IN in
 neighbor 144.228.242.172 route-map Sprint-IN in
 neighbor 144.228.242.172 route-map OUT out
 neighbor 144.228.242.172 filter-list 20 in
 neighbor 144.228.242.172 filter-list 10 out
 no auto-summary
!
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0
ip route 0.0.0.0 0.0.0.0 Serial1/0
ip route 0.0.0.0 0.0.0.0 Serial1/1
ip route 0.0.0.0 0.0.0.0 Serial0/1
ip route 12.123.145.122 255.255.255.255 Serial1/0
ip route 12.123.145.122 255.255.255.255 Serial1/1
ip route 66.185.224.0 255.255.240.0 66.185.224.3
ip route 66.185.228.0 255.255.254.0 66.185.224.4
ip route 66.185.232.0 255.255.254.0 66.185.239.41
ip route 66.185.234.0 255.255.255.0 66.185.239.41
ip route 66.185.236.0 255.255.255.0 66.185.239.41
ip route 66.185.237.0 255.255.255.0 66.185.239.41
ip route 66.185.238.0 255.255.255.0 66.185.239.41
ip route 66.185.239.44 255.255.255.252 66.185.239.41
ip route 66.185.239.48 255.255.255.252 66.185.239.41
ip route 66.185.239.52 255.255.255.252 66.185.239.41
ip route 144.228.242.172 255.255.255.255 Serial0/0
ip route 144.228.242.172 255.255.255.255 Serial0/1
!
ip as-path access-list 10 permit ^$
ip as-path access-list 20 permit ^1239_[0-9]*$
ip as-path access-list 21 permit ^7018_[0-9]*$
ip as-path access-list 22 permit ^7011_[0-9]*$
!
!
ip prefix-list No-Default-IN seq 5 deny 0.0.0.0/0 le 1
ip prefix-list No-Default-IN seq 10 permit 0.0.0.0/0 ge 2
access-list 1 permit 66.185.224.0 0.0.15.255
access-list 11 permit 0.0.0.0 63.255.255.255
access-list 11 permit 64.0.0.0 63.255.255.255
access-list 11 permit 128.0.0.0 63.255.255.255
access-list 11 permit 192.0.0.0 7.255.255.255
access-list 21 permit 0.0.0.0 31.255.255.255
access-list 21 permit 64.0.0.0 15.255.255.255
access-list 22 permit 32.0.0.0 31.255.255.255
access-list 22 permit 80.0.0.0 15.255.255.255
access-list 23 permit 96.0.0.0 31.255.255.255
access-list 23 permit 160.0.0.0 15.255.255.255
access-list 24 permit 128.0.0.0 31.255.255.255
access-list 24 permit 176.0.0.0 15.255.255.255
access-list 24 permit 208.0.0.0 15.255.255.255
access-list 24 permit 192.0.0.0 7.255.255.255
access-list 25 permit 200.0.0.0 7.255.255.255
access-list 26 permit 224.0.0.0 31.255.255.255
access-list 100 permit ip 66.185.224.0 0.0.15.255 any
access-list 100 deny   tcp any any eq 3
access-list 100 deny   ip any any log
access-list 102 deny   icmp any any redirect
access-list 102 deny   ip host 127.0.0.1 any
access-list 102 deny   tcp any any eq 3128
access-list 102 deny   tcp any any eq 1080
access-list 102 deny   ip 10.0.0.0 0.255.255.255 any
access-list 102 deny   ip 172.16.0.0 0.15.255.255 any
access-list 102 deny   ip 192.168.0.0 0.0.255.255 any
access-list 102 deny   tcp any any range 137 139
access-list 102 deny   udp any any range netbios-ns netbios-ss
access-list 102 permit ip any any
route-map Sprint-IN permit 10
 match as-path 20
 set weight 100
!
route-map Sprint-IN permit 20
 match ip address 21 22
 set weight 75
!
route-map Sprint-IN permit 30
 match ip address 23 25
 set weight 50
!
route-map Sprint-IN permit 40
 match ip address 24 26
 set weight 25
!
route-map OUT permit 10
 match ip address 1
 match as-path 10
!
route-map at&t-IN permit 10
 match as-path 21
 set weight 100
!
route-map at&t-IN permit 20
 match ip address 24 26
 set weight 75
!
route-map at&t-IN permit 30
 match ip address 23 25
 set weight 50
!
route-map at&t-IN permit 40
 match ip address 21 22
 set weight 25
!
route-map CZN-IN permit 10
 match as-path 22
 set weight 100
!
route-map CZN-IN permit 20
 match ip address 25 26
 set weight 75
!
route-map CZN-IN permit 30
 match ip address 21 24
 set weight 50
!
route-map CZN-IN permit 40
 match ip address 22 23
 set weight 25
!
snmp-server community public RO
snmp-server enable traps tty
!
line con 0
line aux 0
line vty 0 4
 password XXX
 login
!
ntp clock-period 17179974
ntp server 66.185.224.15
ntp server 66.185.224.16
!
!
end

RTR01 dmesg:
OpenBSD 3.8-stable (GENERIC) #1: Fri Jan 13 22:27:34 MST 2006
    [EMAIL PROTECTED]:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel Pentium III ("GenuineIntel" 686-class) 731 MHz
cpu0: 
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE
real mem  = 536449024 (523876K)
avail mem = 482590720 (471280K)
using 4278 buffers containing 26927104 bytes (26296K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(00) BIOS, date 08/04/03, BIOS32 rev. 0 @ 0xffe90
pcibios0 at bios0: rev 2.1 @ 0xf0000/0x10000
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfc2c0/144 (7 entries)
pcibios0: PCI Interrupt Router at 000:15:0 ("ServerWorks ROSB4 SouthBridge" rev 
0x00)
pcibios0: PCI bus #1 is the last bus
bios0: ROM list: 0xc0000/0x8000 0xc8000/0x6000 0xec000/0x4000!
cpu0 at mainbus0
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "ServerWorks CNB20LE Host" rev 0x05
pchb1 at pci0 dev 0 function 1 "ServerWorks CNB20LE Host" rev 0x05
pci1 at pchb1 bus 2
ppb0 at pci1 dev 2 function 0 "Intel i960 RM PCI-PCI" rev 0x01
pci2 at ppb0 bus 3
ahc1 at pci2 dev 4 function 0 "Adaptec AIC-7899 U160" rev 0x01: irq 10
scsibus0 at ahc1: 16 targets
sd0 at scsibus0 targ 0 lun 0: <QUANTUM, ATLAS 10K 9SCA, UCIE> SCSI3 0/direct 
fixed
sd0: 8683MB, 10042 cyl, 6 head, 295 sec, 512 bytes/sec, 17783249 sec total
sd1 at scsibus0 targ 1 lun 0: <QUANTUM, ATLAS 10K 9SCA, UCIE> SCSI3 0/direct 
fixed
sd1: 8683MB, 10042 cyl, 6 head, 295 sec, 512 bytes/sec, 17783249 sec total
safte0 at scsibus0 targ 6 lun 0: <DELL, 1x4 U2W SCSI BP, 1.16> SCSI2 
3/processor fixed
ahc2 at pci2 dev 4 function 1 "Adaptec AIC-7899 U160" rev 0x01: irq 11
scsibus1 at ahc2: 16 targets
fxp0 at pci1 dev 8 function 0 "Intel 82557" rev 0x08, i82559: irq 11, address 
00:b0:d0:20:8a:b0
inphy0 at fxp0 phy 1: i82555 10/100 PHY, rev. 4
ppb1 at pci0 dev 2 function 0 "DEC 21152 PCI-PCI" rev 0x03
pci3 at ppb1 bus 1
fxp1 at pci3 dev 4 function 0 "Intel 82557" rev 0x05, i82558: irq 11, address 
00:03:47:71:0b:97
inphy1 at fxp1 phy 1: i82555 10/100 PHY, rev. 0
fxp2 at pci3 dev 5 function 0 "Intel 82557" rev 0x05, i82558: irq 10, address 
00:03:47:71:0b:98
inphy2 at fxp2 phy 1: i82555 10/100 PHY, rev. 0
san0 at pci0 dev 4 function 0 unknown vendor 0x1923 product 0x0300 rev 0x01 irq 
11
san1 at pci0 dev 8 function 0 unknown vendor 0x1923 product 0x0300 rev 0x01 irq 
10
vga1 at pci0 dev 14 function 0 "ATI Mach64 GY" rev 0x7a
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
pcib0 at pci0 dev 15 function 0 "ServerWorks ROSB4 SouthBridge" rev 0x4f
pciide0 at pci0 dev 15 function 1 "ServerWorks OSB4 IDE" rev 0x00: DMA
atapiscsi0 at pciide0 channel 0 drive 0
scsibus2 at atapiscsi0: 2 targets
cd0 at scsibus2 targ 0 lun 0: <SAMSUNG, CD-ROM SN-124, S003> SCSI0 5/cdrom 
removable
cd0(pciide0:0:0): using PIO mode 4, DMA mode 2, Ultra-DMA mode 2
ohci0 at pci0 dev 15 function 2 "ServerWorks OSB4/CSB5 USB" rev 0x04: irq 5, 
version 1.0, legacy support
usb0 at ohci0: USB revision 1.0
uhub0 at usb0
uhub0: ServerWorks OHCI root hub, rev 1.00/1.00, addr 1
uhub0: 4 ports with 4 removable, self powered
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0
sysbeep0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pccom0: console
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask ff65 netmask ff65 ttymask ffe7
pctr: 686-class user-level performance counters enabled
mtrr: Pentium Pro MTRR support
ahc1: target 0 using 16bit transfers
ahc1: target 0 synchronous at 80.0MHz DT, offset = 0x1f
dkcsum: sd0 matches BIOS drive 0x80
ahc1: target 1 using 16bit transfers
ahc1: target 1 synchronous at 80.0MHz DT, offset = 0x1f
dkcsum: sd1 matches BIOS drive 0x81
root on sd0a
rootdev=0x400 rrootdev=0xd00 rawdev=0xd02
san0: Bringing interface up.
san0: Configuring A101 PMC T1/E1/J1 Front End
san0: Link connecting...
san0: Bringing interface up.
san1: Bringing interface up.
san1: Configuring A101 PMC T1/E1/J1 Front End
san1: Link connecting...
san1: Bringing interface up.
san2: Bringing interface up.
san2: Configuring A101 PMC T1/E1/J1 Front End
san2: Link connecting...
san2: Bringing interface up.
san2: phase establish
san3: Bringing interface up.
san3: Configuring A101 PMC T1/E1/J1 Front End
san3: Link connecting...
san3: Bringing interface up.
san3: phase establish
san0: T1 RED ON
san0: T1 disconnected!
san1: T1 RED ON
san1: T1 disconnected!


RTR05 dmesg - while san not plugged in:
OpenBSD 3.8-stable (GENERIC) #1: Fri Jan 13 22:27:34 MST 2006
    [EMAIL PROTECTED]:/usr/src/sys/arch/i386/compile/GENERIC
cpu0: Intel Pentium III ("GenuineIntel" 686-class) 731 MHz
cpu0: 
FPU,V86,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,MMX,FXSR,SSE
real mem  = 536449024 (523876K)
avail mem = 482590720 (471280K)
using 4278 buffers containing 26927104 bytes (26296K) of memory
mainbus0 (root)
bios0 at mainbus0: AT/286+(00) BIOS, date 08/04/03, BIOS32 rev. 0 @ 0xffe90
pcibios0 at bios0: rev 2.1 @ 0xf0000/0x10000
pcibios0: PCI IRQ Routing Table rev 1.0 @ 0xfc2c0/144 (7 entries)
pcibios0: PCI Interrupt Router at 000:15:0 ("ServerWorks ROSB4 SouthBridge" rev 
0x00)
pcibios0: PCI bus #1 is the last bus
bios0: ROM list: 0xc0000/0x8000 0xc8000/0x6000 0xec000/0x4000!
cpu0 at mainbus0
pci0 at mainbus0 bus 0: configuration mode 1 (no bios)
pchb0 at pci0 dev 0 function 0 "ServerWorks CNB20LE Host" rev 0x05
pchb1 at pci0 dev 0 function 1 "ServerWorks CNB20LE Host" rev 0x05
pci1 at pchb1 bus 2
ppb0 at pci1 dev 2 function 0 "Intel i960 RM PCI-PCI" rev 0x01
pci2 at ppb0 bus 3
ahc1 at pci2 dev 4 function 0 "Adaptec AIC-7899 U160" rev 0x01: irq 10
scsibus0 at ahc1: 16 targets
sd0 at scsibus0 targ 0 lun 0: <QUANTUM, ATLAS 10K 9SCA, UCIE> SCSI3 0/direct 
fixed
sd0: 8683MB, 10042 cyl, 6 head, 295 sec, 512 bytes/sec, 17783249 sec total
sd1 at scsibus0 targ 1 lun 0: <QUANTUM, ATLAS 10K 9SCA, UCIE> SCSI3 0/direct 
fixed
sd1: 8683MB, 10042 cyl, 6 head, 295 sec, 512 bytes/sec, 17783249 sec total
safte0 at scsibus0 targ 6 lun 0: <DELL, 1x4 U2W SCSI BP, 1.16> SCSI2 
3/processor fixed
ahc2 at pci2 dev 4 function 1 "Adaptec AIC-7899 U160" rev 0x01: irq 11
scsibus1 at ahc2: 16 targets
fxp0 at pci1 dev 8 function 0 "Intel 82557" rev 0x08, i82559: irq 11, address 
00:b0:d0:20:8a:b1
inphy0 at fxp0 phy 1: i82555 10/100 PHY, rev. 4
ppb1 at pci0 dev 2 function 0 "DEC 21152 PCI-PCI" rev 0x03
pci3 at ppb1 bus 1
fxp1 at pci3 dev 4 function 0 "Intel 82557" rev 0x05, i82558: irq 11, address 
00:50:8b:5e:e7:ac
inphy1 at fxp1 phy 1: i82555 10/100 PHY, rev. 0
fxp2 at pci3 dev 5 function 0 "Intel 82557" rev 0x05, i82558: irq 10, address 
00:50:8b:5e:e7:ad
inphy2 at fxp2 phy 1: i82555 10/100 PHY, rev. 0
san0 at pci0 dev 4 function 0 unknown vendor 0x1923 product 0x0300 rev 0x01 irq 
11
san1 at pci0 dev 8 function 0 unknown vendor 0x1923 product 0x0300 rev 0x01 irq 
10
vga1 at pci0 dev 14 function 0 "ATI Mach64 GY" rev 0x7a
wsdisplay0 at vga1 mux 1: console (80x25, vt100 emulation)
wsdisplay0: screen 1-5 added (80x25, vt100 emulation)
pcib0 at pci0 dev 15 function 0 "ServerWorks ROSB4 SouthBridge" rev 0x4f
pciide0 at pci0 dev 15 function 1 "ServerWorks OSB4 IDE" rev 0x00: DMA
atapiscsi0 at pciide0 channel 0 drive 0
scsibus2 at atapiscsi0: 2 targets
cd0 at scsibus2 targ 0 lun 0: <SAMSUNG, CD-ROM SN-124, S003> SCSI0 5/cdrom 
removable
cd0(pciide0:0:0): using PIO mode 4, DMA mode 2, Ultra-DMA mode 2
ohci0 at pci0 dev 15 function 2 "ServerWorks OSB4/CSB5 USB" rev 0x04: irq 5, 
version 1.0, legacy support
usb0 at ohci0: USB revision 1.0
uhub0 at usb0
uhub0: ServerWorks OHCI root hub, rev 1.00/1.00, addr 1
uhub0: 4 ports with 4 removable, self powered
isa0 at pcib0
isadma0 at isa0
pckbc0 at isa0 port 0x60/5
pckbd0 at pckbc0 (kbd slot)
pckbc0: using irq 1 for kbd slot
wskbd0 at pckbd0: console keyboard, using wsdisplay0
pcppi0 at isa0 port 0x61
midi0 at pcppi0: <PC speaker>
spkr0 at pcppi0
sysbeep0 at pcppi0
lpt0 at isa0 port 0x378/4 irq 7
npx0 at isa0 port 0xf0/16: using exception 16
pccom0 at isa0 port 0x3f8/8 irq 4: ns16550a, 16 byte fifo
pccom0: console
pccom1 at isa0 port 0x2f8/8 irq 3: ns16550a, 16 byte fifo
fdc0 at isa0 port 0x3f0/6 irq 6 drq 2
fd0 at fdc0 drive 0: 1.44MB 80 cyl, 2 head, 18 sec
biomask ff65 netmask ff65 ttymask ffe7
pctr: 686-class user-level performance counters enabled
mtrr: Pentium Pro MTRR support
ahc1: target 0 using 16bit transfers
ahc1: target 0 synchronous at 80.0MHz DT, offset = 0x1f
dkcsum: sd0 matches BIOS drive 0x80
ahc1: target 1 using 16bit transfers
ahc1: target 1 synchronous at 80.0MHz DT, offset = 0x1f
dkcsum: sd1 matches BIOS drive 0x81
root on sd0a
rootdev=0x400 rrootdev=0xd00 rawdev=0xd02
san0: Bringing interface up.
san0: Configuring A101 PMC T1/E1/J1 Front End
san0: Link connecting...
san0: Bringing interface up.
san1: Bringing interface up.
san1: Configuring A101 PMC T1/E1/J1 Front End
san1: Link connecting...
san1: Bringing interface up.
san0: Unknown signal (3f).
san0: T1 connected!
san0: Link connected!
san1: Unknown signal (00).
san1: T1 connected!
san1: Link connected!
san2: Bringing interface up.
san2: Configuring A101 PMC T1/E1/J1 Front End
san2: Link connecting...
san2: Bringing interface up.
san3: Bringing interface up.
san3: Configuring A101 PMC T1/E1/J1 Front End
san3: Link connecting...
san3: Bringing interface up.
san2: Unknown signal (3f).
san2: T1 connected!
san2: Link connected!
san3: Unknown signal (00).
san3: T1 connected!
san3: Link connected!

l8rZ,
-- 
andrew - ICQ# 253198 - JID: [EMAIL PROTECTED]
     Proud member: http://www.mad-techies.org

BOFH excuse of the day: I'm sorry a pentium won't do, you need an SGI
    to connect with us.

Reply via email to