Am 11.05.2014 02:34, schrieb Ilia Mirkin:
> Previously the implication was that queries should be disabled during
> blits. However glBlitFramebuffer() is supposed to obey the current
> query, and this new bit will indicate that to the driver.
> 
> Signed-off-by: Ilia Mirkin <imir...@alum.mit.edu>
> Cc: "10.2" <mesa-sta...@lists.freedesktop.org>
> ---
> 
> v1 -> v2:
>   Rename flag to "render_condition_enable" per Marek's suggestion
> 
> Outstanding question: should I add 10.1 to the CC list for this series?
> 
>  src/gallium/include/pipe/p_state.h | 3 +++
>  1 file changed, 3 insertions(+)
> 
> diff --git a/src/gallium/include/pipe/p_state.h 
> b/src/gallium/include/pipe/p_state.h
> index a41c53d..07ce88e 100644
> --- a/src/gallium/include/pipe/p_state.h
> +++ b/src/gallium/include/pipe/p_state.h
> @@ -591,6 +591,9 @@ struct pipe_blit_info
>  
>     boolean scissor_enable;
>     struct pipe_scissor_state scissor;
> +
> +   boolean render_condition_enable; /**< whether to leave current render
> +                                    condition enabled */
>  };
>  
>  
> 

The commit message still is saying "query" in places where it probably
should be render_condition (in both 1/3 and 2/3) but I'm not going to
insist on that. (Query is really a bit misleading, since you'd typically
associate the actual gathering of the values with that, and of course
that is always implicitly disabled with BlitFrameBuffer as it doesn't
generate fragments, even though the implementation probably does.)
1/3 and 2/3 are
Reviewed-by: Roland Scheidegger <srol...@vmware.com>
_______________________________________________
mesa-dev mailing list
mesa-dev@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/mesa-dev

Reply via email to