On Wed, 2014-04-02 at 08:25 +1100, Timothy Arceri wrote: > Thanks Ian, > > Reviewed-by: Timothy Arceri <t_arc...@yahoo.com.au> > > I wasn't aware of this test. I guess the other KHR_debug functions > should be added here also? If so I can create a patch for this later > today unless you just want to do it. > > When I get some time I might also add another dot point to the 'Adding > Extensions' heading in the developer notes about updating > dispatch_sanity and check_table. Just for clarity is my understanding of > the difference between the check table and the dispatch sanity test > correct? > check table test - makes sure an extension that is expected to be > available is actually available? > dispatch sanity - only extensions that a expected be available are > available (nothing extra)?
On second thought maybe it would be better to just add a description to the check_table.cpp file like dispatch_sanity.cpp has. Then a simple dot point can be added to the developer notes something like - The dispatch table tests check_table.cpp and dispatch_sanity.cpp should be updated appropriately with the new extensions functions. These test are run using 'make check' > > Tim > > > On Tue, 2014-04-01 at 13:15 -0700, Ian Romanick wrote: > > From: Ian Romanick <ian.d.roman...@intel.com> > > > > Commit fb78fa58 made the GL_ARB_debug_output functions aliases of the > > GL_KHR_debug output functions. As a result, the function names in > > struct _glapi_table also changed. The table in check_table.cpp used the > > ARB names. > > > > Signed-off-by: Ian Romanick <ian.d.roman...@intel.com> > > Cc: Vinson Lee <v...@freedesktop.org> > > Cc: Timothy Arceri <t_arc...@yahoo.com.au> > > --- > > src/mapi/glapi/tests/check_table.cpp | 8 ++++---- > > 1 file changed, 4 insertions(+), 4 deletions(-) > > > > diff --git a/src/mapi/glapi/tests/check_table.cpp > > b/src/mapi/glapi/tests/check_table.cpp > > index 375645b..89d9073 100644 > > --- a/src/mapi/glapi/tests/check_table.cpp > > +++ b/src/mapi/glapi/tests/check_table.cpp > > @@ -1227,10 +1227,10 @@ const struct name_offset known_dispatch[] = { > > { "glGetShaderPrecisionFormat", _O(GetShaderPrecisionFormat) }, > > { "glReleaseShaderCompiler", _O(ReleaseShaderCompiler) }, > > { "glShaderBinary", _O(ShaderBinary) }, > > - { "glDebugMessageCallbackARB", _O(DebugMessageCallbackARB) }, > > - { "glDebugMessageControlARB", _O(DebugMessageControlARB) }, > > - { "glDebugMessageInsertARB", _O(DebugMessageInsertARB) }, > > - { "glGetDebugMessageLogARB", _O(GetDebugMessageLogARB) }, > > + { "glDebugMessageCallback", _O(DebugMessageCallback) }, > > + { "glDebugMessageControl", _O(DebugMessageControl) }, > > + { "glDebugMessageInsert", _O(DebugMessageInsert) }, > > + { "glGetDebugMessageLog", _O(GetDebugMessageLog) }, > > { "glGetGraphicsResetStatusARB", _O(GetGraphicsResetStatusARB) }, > > { "glGetnColorTableARB", _O(GetnColorTableARB) }, > > { "glGetnCompressedTexImageARB", _O(GetnCompressedTexImageARB) }, > _______________________________________________ mesa-dev mailing list mesa-dev@lists.freedesktop.org http://lists.freedesktop.org/mailman/listinfo/mesa-dev