On 26 November 2013 00:02, Francisco Jerez <curroje...@riseup.net> wrote:
> > + * ARB_shader_image_load_store qualifiers. > + */ > + struct { > + bool read_only; > + bool write_only; > It's hard to come up with a good naming convention for read_only and write_only--should they have underscores (like the GLenum values GL_READ_ONLY and GL_WRITE_ONLY) or not (like the GLSL keywords readonly and writeonly)? I think you've made a reasonable choice to standardize on always using underscores. However, I would appreciate a short comment next to "read_only" and "write_only" to indicate that the corresponding GLSL keywords are "readonly" and "writeonly". With that change, the patch is: Reviewed-by: Paul Berry <stereotype...@gmail.com>
_______________________________________________ mesa-dev mailing list mesa-dev@lists.freedesktop.org http://lists.freedesktop.org/mailman/listinfo/mesa-dev