On 26 November 2013 00:02, Francisco Jerez <curroje...@riseup.net> wrote:

> Add predicates to query if a GLSL type is or contains an image.
> Rename sampler_coordinate_components() to coordinate_components() and
> fix it to support calculating the number of coordinate dimensions of
> image types as well as sampler types.
> ---
>  src/glsl/builtin_functions.cpp        |  2 +-
>  src/glsl/glsl_types.cpp               | 95
> +++++++++++++++++++++++++----------
>  src/glsl/glsl_types.h                 | 19 ++++++-
>  src/glsl/tests/sampler_types_test.cpp |  2 +-
>  4 files changed, 88 insertions(+), 30 deletions(-)
>

If the calls to unreachable() are replaced with assertions (as we've
discussed elsewhere on the list), this patch is:

Reviewed-by: Paul Berry <stereotype...@gmail.com>

I don't have a strong opinion about Topi's suggestion to separate the
sampler and image cases--I could go either way.
_______________________________________________
mesa-dev mailing list
mesa-dev@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/mesa-dev

Reply via email to