I'll fix this issue in v2 series of patches, thanks again!

Hi, I'm an outsider (for everyone who might have not noticed), I
started following the list because I'm interested in the newbie
projects, too.
I think this free should be called regardless of new_data being null,
as this doesn't imply there wasn't any in the original object.
So, I believe it should be:

if( bufObj->Data )
   _mesa_align_free( bufObj->Data );

if( new_data ) {
   bufObj->Data = new_data;
...

_______________________________________________
mesa-dev mailing list
mesa-dev@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/mesa-dev

Reply via email to