Paul Berry <stereotype...@gmail.com> writes: > On 22 March 2013 12:32, Eric Anholt <e...@anholt.net> wrote: > >> Paul Berry <stereotype...@gmail.com> writes: >> > diff --git a/src/mesa/drivers/dri/i965/brw_vs.c >> b/src/mesa/drivers/dri/i965/brw_vs.c >> > index c8ca018..7e941dd 100644 >> > --- a/src/mesa/drivers/dri/i965/brw_vs.c >> > +++ b/src/mesa/drivers/dri/i965/brw_vs.c >> > @@ -66,6 +66,12 @@ brw_compute_vue_map(struct brw_context *brw, struct >> brw_vs_compile *c, >> > vue_map->slots_valid = slots_valid; >> > int i; >> > >> > + /* Make sure that the values we store in >> vue_map->vert_result_to_slot and >> > + * vue_map->slot_to_vert_result won't overflow the signed chars that >> are >> > + * used to store them. >> > + */ >> > + STATIC_ASSERT(BRW_VARYING_SLOT_MAX <= 128); >> >> If the max varying slot was 128, that would be overflowed, right? >> > > Actually, BRW_VARYING_SLOT_MAX is a misnomer--it's actually the max varying > slot + 1. Want me to rename it BRW_NUM_VARYING_SLOT_MAX_PLUS_1 or > something?
BRW_VARYING_SLOT_COUNT would be pretty good.
pgpx2jzcJzjFi.pgp
Description: PGP signature
_______________________________________________ mesa-dev mailing list mesa-dev@lists.freedesktop.org http://lists.freedesktop.org/mailman/listinfo/mesa-dev