On 07/08/2012 04:14 PM, Christopher James Halse Rogers wrote: > Signed-off-by: Christopher James Halse Rogers > <christopher.halse.rog...@canonical.com> > --- > src/mesa/sources.mak | 9 +++++---- > 1 file changed, 5 insertions(+), 4 deletions(-) > > diff --git a/src/mesa/sources.mak b/src/mesa/sources.mak > index 16b1c39..87191fd 100644 > --- a/src/mesa/sources.mak > +++ b/src/mesa/sources.mak > @@ -4,8 +4,8 @@ SRCDIR ?= . > > # this is part of MAIN_FILES > MAIN_ES_FILES = \ > - $(SRCDIR)/main/api_exec_es1.c \ > - $(SRCDIR)/main/api_exec_es2.c > + $(TOP)/src/mesa/main/api_exec_es1.c \ > + $(TOP)/src/mesa/main/api_exec_es2.c
Could we use $(top_builddir) instead of $(TOP)? As your first patch demonstrates, there are really two top-level directories, so $(TOP) is ambiguous/confusing. I'd rather see us stop using it, for clarity. > MAIN_FILES = \ > $(SRCDIR)/main/api_arrayelt.c \ > @@ -249,11 +249,11 @@ STATETRACKER_FILES = \ > PROGRAM_FILES = \ > $(SRCDIR)/program/arbprogparse.c \ > $(SRCDIR)/program/hash_table.c \ > - $(SRCDIR)/program/lex.yy.c \ > + $(TOP)/src/mesa/program/lex.yy.c \ > $(SRCDIR)/program/nvfragparse.c \ > $(SRCDIR)/program/nvvertparse.c \ > $(SRCDIR)/program/program.c \ > - $(SRCDIR)/program/program_parse.tab.c \ > + $(TOP)/src/mesa/program/program_parse.tab.c \ > $(SRCDIR)/program/program_parse_extra.c \ > $(SRCDIR)/program/prog_cache.c \ > $(SRCDIR)/program/prog_execute.c \ > @@ -382,6 +382,7 @@ INCLUDE_DIRS = \ > -I$(TOP)/include \ > -I$(TOP)/src/glsl \ > -I$(TOP)/src/mesa \ > + -I$(TOP)/src/mesa/main \ > -I$(TOP)/src/mapi \ > -I$(TOP)/src/gallium/include \ > -I$(TOP)/src/gallium/auxiliary _______________________________________________ mesa-dev mailing list mesa-dev@lists.freedesktop.org http://lists.freedesktop.org/mailman/listinfo/mesa-dev