Kenneth Graunke <kenn...@whitecape.org> writes:

> This will be used by u_transfer_helper.c shortly, in order to split
> packed depth-stencil into separate resources.
> ---
>  src/gallium/auxiliary/util/u_format.h | 21 +++++++++++++++++++++
>  1 file changed, 21 insertions(+)
>
> diff --git a/src/gallium/auxiliary/util/u_format.h 
> b/src/gallium/auxiliary/util/u_format.h
> index f421222f854..e66849c16b1 100644
> --- a/src/gallium/auxiliary/util/u_format.h
> +++ b/src/gallium/auxiliary/util/u_format.h
> @@ -557,6 +557,27 @@ util_format_is_depth_and_stencil(enum pipe_format format)
>            util_format_has_stencil(desc);
>  }
>  
> +/**
> + * For depth-stencil formats, return the equivalent depth-only format.
> + */
> +static inline boolean
> +util_format_get_depth_only(enum pipe_format format)

Given that the equivalent function for stencil is
util_format_stencil_only(), can we get naming consistency?  Other than
that, r-b.

Attachment: signature.asc
Description: PGP signature

_______________________________________________
mesa-dev mailing list
mesa-dev@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/mesa-dev

Reply via email to