My thoughts is "driver" and "kernel_driver" don't need to appear at the same time, so "driver" can be reused for simplicity.
If you guys still prefer adding "kernel_driver" for clean/clear, I'd also suggest <device driver="loader" kernel_driver="amdgpu"> to make this new attribute only affect loader device. Regards, Qiang ________________________________________ From: Michel Dänzer <mic...@daenzer.net> Sent: Thursday, August 2, 2018 5:37:02 PM To: Yu, Qiang Cc: mesa-dev@lists.freedesktop.org Subject: Re: [Mesa-dev] [PATCH 2/2] loader: add dri_driver drirc option to override dri driver to load On 2018-08-01 01:10 PM, Qiang Yu wrote: > drirc implementation of MESA_LOADER_DRIVER_OVERRIDE which can be > used to override dri driver to load. > > Usage: > > override dri driver for device with spec kernel driver name: > <device driver="k:kernel_driver_name"> > <option name="dri_driver" value="new_dri_driver" /> > </device> I still think a separate kernel_driver attribute would be cleaner and clearer, and Emil seems to agree. Can you elaborate why you think that would be overkill? -- Earthling Michel Dänzer | http://www.amd.com Libre software enthusiast | Mesa and X developer _______________________________________________ mesa-dev mailing list mesa-dev@lists.freedesktop.org https://lists.freedesktop.org/mailman/listinfo/mesa-dev