On Wed, Mar 14, 2018 at 2:01 AM, Timothy Arceri <tarc...@itsqueeze.com>
wrote:

> This will be used to support uniform packing.
> ---
>  src/mesa/state_tracker/st_glsl_types.cpp | 43
> ++++++++++++++++++++++++++++++++
>  src/mesa/state_tracker/st_glsl_types.h   |  1 +
>  2 files changed, 44 insertions(+)
>
> diff --git a/src/mesa/state_tracker/st_glsl_types.cpp
> b/src/mesa/state_tracker/st_glsl_types.cpp
> index e57fbc8f31..5dbfab4dce 100644
> --- a/src/mesa/state_tracker/st_glsl_types.cpp
> +++ b/src/mesa/state_tracker/st_glsl_types.cpp
> @@ -106,3 +106,46 @@ st_glsl_storage_type_size(const struct glsl_type
> *type, bool is_bindless)
>     }
>     return 0;
>  }
> +
> +int
> +st_glsl_type_size_scalar(const struct glsl_type *type)
>

I don't know what "type_size_scalar" means, but the function seems to
return the type size in dwords. I'd like a clearer name.

Marek
_______________________________________________
mesa-dev mailing list
mesa-dev@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/mesa-dev

Reply via email to