On 03/06/2018 12:48 AM, mathias.froehl...@gmx.net wrote:
From: Mathias Fröhlich <mathias.froehl...@web.de>

Hi,

The change basically strips down gl_vertex_array to two pointers
into the VAO. Consequently the current vertex attributes in the
vbo module need to be represented by structs present in the VAO
instead of gl_vertex_array instances.
The change prepares the backends somewhat to use the _DrawVAO for
draw operations in the longer term.

The change introduced no piglit quick regressions on classic swrast
to test drivers using tnl, i965 and radeonsi.

Please review!
Thanks!

Looks good to me. Definitely seems like another step in the right direction.

Just two minor comments:

1. A lot of local vars are named "glarray" and "glbinding". I'd suggest dropping the "gl" part since it doesn't really help with readability (everything's "gl" in this code :-) ).

2. In a future patch you could probably simplify st_pipe_vertex_format() to be:

enum pipe_format
st_pipe_vertex_format(const struct gl_array_attributes *attribs)


Reviewed-by: Brian Paul <bri...@vmware.com>

_______________________________________________
mesa-dev mailing list
mesa-dev@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/mesa-dev

Reply via email to