There are a number of small style cleanups and simplifications in this series, but the main changes are: - use a mako template to generate the header and code rather than prints - be python 3.x ready (the goal isn't to write python 3 code, but to write code that is easy to port or hybridize) - generate the header and the code in one go
I've put emphasis on the readability of the template rather than the readability of the output code, it's relatively easy to pipe the code through 'indent' to make it more readable. Notable changes in Version 2: - Pass XML file via an argument - add flag to control output directory - Attempt to update android makefiles Dylan Baker (14): anv: anv_entrypoints_gen.py: use a main function anv: Use python style in anv_entrypoints_gen.py anv: make constants capitals in anv_entrypoints_gen.py anv: don't pass xmlfile via stdin anv_entrypoints_gen.py anv: split main into two functions in anv_entrypoints_gen.py anv: convert header generation in anv_entrypoints_gen.py to mako anv: convert C generation to template in anv_entrypoints_gen.py anv: generate anv_entrypoints.{h,c} in one command anv: anv-entrypoints_gen.py: rename hash to cal_hash. anv: anv_entrypoints_gen.py: use reduce function. anv: use dict.get in anv_entrypoints_gen.py anv: don't use Element.get in anv_entrypoints_gen.py anv: use cElementTree in anv_entrypoints_gen.py anv: Remove dead prototype from entrypoints src/intel/vulkan/Android.mk | 7 +- src/intel/vulkan/Makefile.am | 10 +- src/intel/vulkan/anv_entrypoints_gen.py | 601 ++++++++++++------------- 3 files changed, 312 insertions(+), 306 deletions(-) base-commit: a9c488f2858f8a383dd50e557ec8a832bcb35f47 -- git-series 0.9.0 _______________________________________________ mesa-dev mailing list mesa-dev@lists.freedesktop.org https://lists.freedesktop.org/mailman/listinfo/mesa-dev