On Thu, Sep 29, 2016 at 3:03 PM, Anuj Phogat <anuj.pho...@gmail.com> wrote: > On Thu, Sep 29, 2016 at 11:45 AM, Ilia Mirkin <imir...@alum.mit.edu> wrote: >> 2016-09-29 14:42 GMT-04:00 Anuj Phogat <anuj.pho...@gmail.com>: >>> Signed-off-by: Anuj Phogat <anuj.pho...@gmail.com> >>> Cc: Ilia Mirkin <imir...@alum.mit.edu> >>> --- >>> src/mesa/main/get.c | 6 ++++++ >>> src/mesa/main/get_hash_params.py | 8 ++++---- >>> 2 files changed, 10 insertions(+), 4 deletions(-) >>> >>> diff --git a/src/mesa/main/get.c b/src/mesa/main/get.c >>> index e7ebc7f..64a4b0e 100644 >>> --- a/src/mesa/main/get.c >>> +++ b/src/mesa/main/get.c >>> @@ -405,6 +405,12 @@ static const int >>> extra_ARB_viewport_array_or_oes_geometry_shader[] = { >>> EXTRA_END >>> }; >>> >>> +static const int extra_ARB_viewport_array_or_oes_viewport_array[] = { >>> + EXT(ARB_viewport_array), >>> + EXT(OES_viewport_array), >>> + EXTRA_END >>> +}; >> >> I originally had this patch in my series but took it out - why isn't >> it reasonable to just flip on the ARB_viewport_array bit and move on? >> (i.e. decree that in order to enable OES_viewport_array you must also >> enable ARB_viewport_array) >> > I don't see a big reason to prefer one or the other. I noticed we are > doing it this way for few other gles extensions and found it slightly > cleaner. Otherwise I don't have a strong preference.
I don't feel too strongly about it either. If you think this is better, this series is Reviewed-by: Ilia Mirkin <imir...@alum.mit.edu> _______________________________________________ mesa-dev mailing list mesa-dev@lists.freedesktop.org https://lists.freedesktop.org/mailman/listinfo/mesa-dev