On Wed, Feb 10, 2016 at 10:13:11PM -0800, Ian Romanick wrote: > From: Ian Romanick <ian.d.roman...@intel.com> > > Also change the name of the function to > _mesa_meta_framebuffer_texture_image. The function is basically a > wrapper around _mesa_framebuffer_texture (which is used to implement > glFramebufferTexture1D and friends), so it makes sense for it's name to > be similar to that. > > The next patch will clean _mesa_meta_framebuffer_texture_image up > considerably. > > Signed-off-by: Ian Romanick <ian.d.roman...@intel.com>
I'm not super familiar with the logic, but I tried comparing the implementation of the currently called functions to your changes. Patches 1-8 look good to me and are Reviewed-by: Topi Pohjolainen <topi.pohjolai...@intel.com> _______________________________________________ mesa-dev mailing list mesa-dev@lists.freedesktop.org https://lists.freedesktop.org/mailman/listinfo/mesa-dev