have a couple of minor questions about port naming that are partly related to a recent ticket (55241):
1) lowercase versus CamelCase We seem to use CamelCase naming mostly for ports that provide software with a graphical user interface, eg AquaLess. But not exclusively (e.g. SourceKitten). For instance, we have HandBrakeCLI and HandBrake. If I have a “mediainfo” port providing a CLI tool, should I use “MediaInfo-gui” or “mediainfo-gui” for the WIMP version? 2) libsomething versus somethinglib I recently added the mediainfolib port and pondered whether it should be named libmediainfo. On Repology, 14 repos use the latter, compared to 3 using "mediainfolib", even though the GitHub project is named “MediaInfoLib”. https://repology.org/metapackages/?search=mediainfo&maintainer=&category=&inrepo=¬inrepo=&minspread=&maxspread= Is there a consensus on either of these issues? I suspect that we don’t need to make hard and fast rules about either of these issues, but maybe we should have at least a brief mention on a wiki page? Craig