Questions to LyX documentation
General comments
I have used Scientific WorkPlace since 1994, and been happy with that. However, SWP is missing some features that I need, and has its idiosyncrasies. Before SWP, I used «raw» LaTeX (1992-1994) via emacs. Before that, I used FrameMaker (1988-1991), and really liked FM; the reason why I shifted from FM to LaTeX was that my new employer didn’t want to pay for FM. Since then, I have become accustomed to the superior output quality of LaTeX (as compared to e.g. FM, Word, etc.), and the good quality templates/styles. I do not consider myself a “LaTeX hacker”, but I know some of the basics.  
I installed LyX around July 7, 2016, and below, I refer to documentation dated July 5, 2016. Some of my comments reflect my background with SWP. Ah, and I use Windows 10.
“Introduction to LyX”
This is an ok introduction. There was little of interest to me, but that is because of my background.
“The LyX Tutorial”
Again, in general ok, but I have a number of general questions:
1. Using a high resolution screen on a laptop, my first question is: 
a. How do I increase the size of the menu icons? (I have already been helped with this question, but I’m sure others will have this question.)
2. Similarly, with relatively small screens and high resolution, fonts in the text window are small. I have learned that I can zoom in using the scroll wheel on a mouse. But I have to redo this every time I start up LyX. Question: 
a. How can I define the start-up text window zoom?
3. On p. 19, section 3.4.2, my “first cross reference” happened to be of type “<reference> on page <page>”. Since I had a very short document and the reference and key was on the same page, nothing was shown. This puzzled me. I have later read that this is supposed to be the behavior when the cross reference and the key is on the same page, but perhaps it is useful to comment on this already in the tutorial? Since most starters will have a very short document? Suggestion:
a. Comment already in the tutorial on the use of non-standard cross references, and what happens with cross-reference and key on the same/neighbor page. 
4. On p. 19, section 3.4.2: it says “Protected Space (shortcut undefined)”, which doesn’t look good. Suggestion:
a. I miss a complete and updated keyboard shortcut list… it would be nice if I could find a continuously updated list somewhere.
5. On p. 19, section 3.4.2, it is explained how one can Copy as Reference, and paste using Edit>Paste (or: Ctrl+v). Suggestion:
a. Perhaps it is possible to introduce a Paste Special possibility (right-click, Paste Special) and choose amongst the possible reference styles? (refer to the key, refer to the page of the key, refer to the key + page of key, etc.)
6. In SWP, I’m used to defining “fragments”, i.e. named TeX/LaTeX structures. Thus, I can mark a portion of the document and save this under a certain fragment-name (a file). Then I can use Ctrl+fragment-name to invoke it. In the LyX world, this would be similar to \fragment-name . Perhaps LyX has another way to do the same thing? 
7. Macros… It is not 100% clear to me what a “macro” is in LyX, but I have missed this feature in SWP (or an easy way to do it). Consider the following need…
a. I’m writing my lecture notes on modeling of dynamic systems, and need symbols for (i) a scaling quantity, (ii) a dimesionless variable, (iii) an operating trajectory, (iv) the standard state of chemical substances/species, and (v) a hypothetical pure substance state.
b. I have played around with different symbols for the above, typically superscripted symbols for (i), (ii), (iv) and (v), and subscript for (iii). The scientific standard for (iv) is superscripted “\circ”, although historically, the so-called “plimsoll” symbol was used.
c. In playing around, I have defined my chosen symbols as *fragment* in SWP. Thus, to insert the “standard state” symbol, I have typed Ctrl+std (in LyX, this would be \std). 
d. The problem with the above use of “fragment”, is that the symbol in question is immediately inserted into the math expression. What if I later decide to change using subscript “\triangleright” as symbol for operating trajectory, and instead use “\circ” to symbolize operating trajectory? Then I have to use search-and-replace of my previous symbol, and then run into conflict with the other use of “\circ” (superscripted) for standard state. Even worse if I use e.g. “+” as one of the (i)-(v) symbols – if I use search-and-replace to change the “+” to something else, I also mess up all equations containing “+”.
e. Thus, ideally, I need to define a macro – in the preamble? – and insert the macro name. Thus, if I change the symbol/meaning of the macro in the preamble, there is no problem in messing up my document.
f. But then… it looks ugly to have e.g. “\std” in the equations, so on the other side, it would be nice if the mapping from “\std” to symbol was actually previewed in LyX. I don’t know if this is possible…
OK – my point 7 does perhaps not belong in the Tutorial…, although macros are mentioned…
“The LyX User’s Guide”
Overall, very good. Still:
1. How can I set the start-up zoom level of the text window? (See a point 2 in the previous section.)
2. Suppose that I want to expand on an Article, and make it into a Book. It would be very handy if there was a way to increase the level of the headings by one… Thus, “section” in Article should be “chapter” in the Book, “subsection” in the Article should be “section” in the Book, etc.
3. In longer documents/books, it is common to have a “Preface”, etc. in the first part which is paginated using roman numbers. 
a. How can I insert an unnumbered chapter in the section which is paginated by roman numbers, while at the same time have this “section” appear in the Table of Contents?
b. Sometimes, one wants to have more than one section like “Preface”, e.g., “Acknowledgement”, etc.
c. It would be useful to have a description of this in the User’s Guide.
4. P. 3.3, section 3.3.4.4, it is stated that “The title of this section is a good example of using this feature”, referring to “Short Titles of Headings”. Since I read the printed version of the document, I was puzzled because I couldn’t see any long title needing a short title. 
a. This feature would be better illustrated if you actually inserted a very long title in subsection 3.3.4.4…
5. P. 27, section 3.3.7.2 Resumed Enumeration… I have not been able to find a style “Enumerate-Resume” *anywhere*.
6. P. 69, section 4.5.2. In the item “Header”, there is a minor typo: “of the longtable. except…”
7. P.73, section 4.6.2. When inserting Figure Floats, why are not *centered* Graphics the default??? I’m kind of tired of repeating centering the graphics… In SWP, I could have defined a fragment to fix this…
8. P. 73-74, section 4.6.2: you explain how to insert two figures in the same figure float. But you don’t explain how to put the side by side, or how to put one above the other. In the Embedded Objects manual, you say more or less the same, but that one is also vague on how to achieve it.)
9. P. 75, section 4.7 Minipages. In the last line, you refer to the “Embedded Object” manual. OK – this is the name given in the Help menu, but since I had printed the manual, it took a while before I realized that this is the “LyX’s detailed Figure, Table, Floats, Notes, Boxes and External Material manual”.
10. P. 89, section 6.2.1: “Unnumbered sections are not listed in the TOC”. What if I want to list it in the TOC, as e.g. the Preface, etc.?
11. P. 89, section 6.2.2… OK – examples are not floats, but it would be useful to be able to make a List of Examples. And a List of Theorems, etc. And what about a List of Program Listing – even if I don’t use a floating Listings box?
12. P. 90, section 6.3.2: I would have assumed that any cross-reference would be turned into a hyperlink, with jump to the location of the key. You write “The hyperlink type can be a weblink…, an Email address…, or a link to a file”. You don’t include a cross-reference. (Although I seem to recall that hyperlinks from cross-references to keys are discussed elsewhere.)
13. P. 92, section 6.5.2: “To use a database, use the menu Insert>List/TOC>BibTeX Bibliography”. Can you say something about where this list should be inserted in the document, and whether there is a relation to where it is inserted, and where it appears in the printed document? E.g., can I insert it anywhere? Or do I have to insert it at the end of the document if I want it to appear at the end of the document? [Personally, I prefer to have the bibliography appear at the end of the document, with only the (subject) index coming after the bibliography.)
“LyX’s detailed Figure, Table, Flotas, Notes, Boxes and External Material manual”
Overall, very good. Still:
1. P. 3-4, section 1.2: (i) can I have maximum 2 graphics elements side by side, or any number of them? (ii) how do I specify whether they are side by side, or on top of each other?
a. Is the answer so ridiculously simple that I control the layout by inserting line shifts? And that I can have any number of them – in principle?
b. It would be nice with a brief comment on this.
2. P. 23, section 2.8.2.1 – first line has a typo: “Multicolumns have there own…”: “there”  “their”.
3. P.69, chapter 5: I experimented with inserting a Box with shaded background to accentuate examples. It took a while before I found out that minipages do not allow text to flow from one page to another, and that I need to set the “Inner Box” to “None” in order to achieve this for multipage examples… Perhaps this could have been commented on.
4. P. 93, chapter 8: It took a while before I discovered that in order to set the font of a listing to what I want, I first have to go to the Document/Settings…/Fonts and set the typewriter font to something I like, and *in addition* choose the font in the listing box. This could perhaps have been made clearer.
5. P. 93, chapter 8: it *seems* like fonts LuxiMono and BeraMono *do not* give bold face fonts for syntax highlighting when I specify programming language (e.g. Python). It seems like both Courier and Latin Modern Typewriter provides bold face, though. So there is possibly some incorrect information here??
6. P. 93… while Insert/Program Listing, the Default Font is always chosen. How can set up LyX so that it always uses the Typewriter font??
7. I essentially use the following programming languages: MATLAB, Python, and Modelica. There is no support for Modelica in LyX. However, a config file exists (developed by my colleague Dietmar Winkler, and another guy):  https://raw.githubusercontent.com/modelica-tools/listings-modelica/master/listings-modelica.cfg . Prosjekt side:  https://github.com/modelica-tools/listings-modelica
a. How can I add the config file for Modelica to LyX?
b. Can you add support for Modelica listing in an update to LyX?

“LyX’s detailed Math manual”
Overall, very good. Still:
1. This comment is valid for several of the manuals…
a. I *really* miss a complete overview of keyboard shortcuts. Including the “mnemonics”…
i. First, you should explain the standard Windows (or Linux or OSX) way of shortcuts to menus. In Windows, press and release Alt, then type the underlined letters/numbers in sequence.
ii. I *assume* that the mnemonics of Alt+M X is that it is something to do with math. (In this case, Alt+M means press and keep Alt, while hitting the M key).
iii. I don’t know what the mnemonics of Alt+C X is… But you should explain the logical structure of these shortcuts.
iv. Is it possible to *change* the shortcuts? If so, where? 
v. Some shortcuts may become “impossible” in non-English keyboards… E.g. if a symbol that is on a given key on the English keyboard is moved to shifted key on a non-English keyboard. Thus, if it is necessary to simultaneously hit 4 keys, things may make it useful to change shortcuts in certain languages/keyboards…
2. P. 10, etc. section 4: Is it possible to add separation lines between matrix columns? Like dotted lines, etc.? 
3. P. 28, “Advice for integrals”. Why not introduce a macro or something for the differentiation operator? And I assume this typesetting advice is just as valid for derivtives, e.g. dx/dt?
4. P. 40, first line: typo… “functionwhich” -> “function which”.
5. P. 40, section 15.2: it would be nice if you stated whether self-defined functions/operators are previewed in LyX, or if they appear with TeX code.
6. P. 57, section 20: here, and I think also several other places, you state that shortcut Alt+C R gives upright font style, with reference to Section 11.1. But in Section 11.1 p. 32-33, it is *not clear* what you refer to. And if you have short-cuts for these font styles, why not list the shortcuts? E.g. in the table p. 32…
7. P. 60, etc., section 22 on User-defined Commands… it would be nice if this section was extended and made a little bit clearer. Should commands be inserted in the text box of Document/Settings…/LaTeX Preamble?
8. Somewhere, I found tips for inserting numbers with units: \unittwo… and probably to use \mathrm to insert units without a number. This information should probably have a much more prominent place in the math section… 
Classes/styles
I have just been through a painful process of publishing in the IEEE/EDAS system… Painful, in the sense that IEEE recently modified their conference style. And even more painful because even if I used their  latest template, the uploading of my article gave warnings wrt. margins…
Question:
· Where can I find documentation about how to incorporate an update of the IEEE template in LyX?


