Michael Gerz <[EMAIL PROTECTED]> writes:

| Lars Gullik Bjønnes wrote:
| 
| >Michael Gerz <[EMAIL PROTECTED]> writes:
| >
| >|                && oldpar.isLineSeparator(old.pos())
| >|                && oldpar.isLineSeparator(old.pos() - 1)
| >|                && oldpar.lookupChange(old.pos() - 1).type != 
Change::DELETED) {
| >| -                  // We need to set the text to Change::INSERTED to
| >| -                  // get it erased properly
| >| -                  oldpar.setChangeType(old.pos() -1, Change::INSERTED);
| >| -                  oldpar.erase(old.pos() - 1);
| >| +                  oldpar.erase(old.pos() - 1, false); // do not track 
change
| >
| >Perhaps we should use a enum to make the code in itself clearer.
| >
| Good idea.
| 
| >oldpar.erase(old.pos() - 1, Tracking::Off);
| >
| Tracking::Off will actually be Change::Tracking::off.
| 
| Question: Should "off" be "OFF"? The coding rules suggest "off" for
| enum values, however upper case is used all over the place.

off.

Reserve upper case for smelly macros

-- 
        Lgb

Reply via email to