Am Sonntag, 23. April 2006 06:49 schrieb Bo Peng: > Will be applied to 1.5.x if no objection is heard. Someone may want to > change configure.m4 so that this can be applied to 1.4.x as well.
Please try to convince Jean-Marc to use configure.py instead, We don't have the reasources to do this double work. > Index: src/support/filetools.h > =================================================================== > --- src/support/filetools.h (revision 13715) > +++ src/support/filetools.h (working copy) > @@ -266,6 +266,13 @@ > > cmd_ret const runCommand(std::string const & cmd); > > +/** view a file, with given command and parameter. > + * \param filename > + * \param mode "open" or "edit" > + * \returns whether or not the file is viewed (or edited) successfully. > + */ > +bool autoViewFile(std::string const & filename, std::string const & mode="open"); This function is misnamed: a "View" method should not "edit". The mode argument is also misnamed. Please use something like bool autoViewFile(std::string const & filename); bool autoEditFile(std::string const & filename); or enum openFileMode { view, edit }; bool openFile(std::string const & filename, openFileMode mode = view); > Index: lib/configure.py > =================================================================== > --- lib/configure.py (revision 13713) > +++ lib/configure.py (working copy) > @@ -262,6 +262,55 @@ > ''') > > > +def autoFormatEntries(): This is error prone. When I want to add a new format I have to touch two different places. Please hold back the configure.py change. I have an almost finished different solution that does not need it. The rest is fine with me. Georg