> There are two sets of things for stuff like borders and alignment,
> which behave differently. Edwin  what were  you planning here ?

you mean with QTabularDialog.ui? Write the controller in such a way that it 
can work on the selection or in case of no selection the active cell.

f.e. when setLeftBorder()

loop over selected cells {
        if cell==multicolumn {
                set leftmulticolborder
        } else if !leftcolborder {
                set leftcolborder
        }
}

i find the separate tabs for cols/cells which are basically identical very 
annoying and would like to avoid this for qt. iirc this was new in 1.2 and it 
makes me usually pass through at least 2 but often 3 tabs when i work on my 
tables. i also think that ideally the user should not be bothered with the 
distinction of cells and columns. i know that in latex tables are a bit 
restrictive but the above would be a big improvement in useability imho.

> btw, the widget names are very inconsistent: LongtabularCB vs.
> rotateCellCB etc. Can you fix this please.

done

best, Ed.

Reply via email to