On Mon, 2002-10-21 at 06:22, John Levon wrote: > On Mon, Oct 21, 2002 at 06:13:23AM +0930, Darren Freeman wrote: > > > BTW you should get yourself a wheel mouse if you can.. They're really > > I should... > > > Well, if you like them, then you will add them. Am I right? Well then I > > would like to refresh whatever you have done to the tree. > > right. just do : > > cvs update > > it may have some "conflicts" which show up in the source fiels like : > > <<<< > your version of the change > ... > ==== > my version > ... > >>>> > > and you are supposed to resolve this by hand (or just rm the file then > cvs update the file)
Okie dokie.. > > Noted.. Bad habit, comes from wanting people to notice the comment > > because it needs fixing. > > OK then you should fix it too :) In future, I may change things all over the place. For now, you know where you put me. There may come a time when you wish you hadn't let me loose =) > > I stayed out of BufferView because I didn't know why there was also a > > BufferView_pimpl (maybe the latter is a teenaged version?) > > Something like that. It's an ugly way to reduce file dependencies. In > theory. > > > > I'll let you do that =) I'll break something, just you watch me.. > > OK I will clean up your patch. > > > It does, it's a duplicate. I think all such comments should be > > duplicated like I have done. But it's up to you. > > What editor do you use ? It should be very very easy to switch between > the header and the source file ... Which is why it's so easy to copy the comments of course! Well actually if I had put more effort into it the comment block above the function would have described quite a bit, like what the return values are, what the parameters do, what to look out for, who should call it, etc. But as I haven't seen a LyX standard comment block for this I decided to just wait on it. Yes, I know this is one of the simplest functions in LyX, that's not the point ;) I would comment a stub like that if I wrote one.. It wouldn't have a lot of info in it but it would still say what it's doing there and what it would become. > > Because it signals intent to the reader. How many bugs have you seen > > that were related to somebody forgetting that their type was implicitly > > signed or unsigned, while coding at 5am? > > More than a few, but I don't think it's a readability win in this case. Well, it's a suggestion anyway. > > grrr... oh well... you're the boss, Boss. > > Nah, Lars is the boss. I'm just some scmoe. What does that make me? "Power user", whoopee sounds like I can walk through walls =) > > Clearly we need a WYSIWYM code editor.. Can LyX edit it's own code yet? > > http://mindprod.com/scid.html is what we need. I'm impressed. And it would make reverse-engineering binaries so much easier =) Screw the C code with decompiler-generated tokens. Rename once and the code gets a bit easier to follow. Optimise the tree and the weirdness goes away.. Ahem! Not that I would do that ;) > > Oh well.. It worked =) I would be tempted to find another value for > > lineHeight to avoid the changing scroll speed. If there were a global > > way of finding the defaultHeight() for the standard environment then it > > would be what I was after. Currently it changes depending on the style > > you're looking at at the time. > > It doesn't actually. defaultHeight() is constant for a particular > document setup. it's the setting of the cursor that changes how "fast" > the document scrolls by. Well then the problem is a bit big for me =) > > More info please. You mean if (newFirstY < std::min) etc? OK. Didn't > > know they were there =) > > No, you can pin the value with new = std::min(minval, std::max(maxval, old) Cool. > > Well to a person who just opened a text editor on this file, having > > never seen LyX source, it gives an enormous amount of information. > > > > And as a habit I document every logical section of code with a similar > > heading. It improves readability enormously, and reduces the time you > > spend looking at statements as you remember what they do. I know that > > the statement I documented was obvious to you, you've been staring at > > the code for a while I gather... But after 6 months of absence are you > > sure the comment wouldn't be handy? > > Quite sure. Bear in mind that the more vertical space you use up, the > less of the algorithm you can see on the screen. Each function should > fit in one screenful. Yeah I've heard that, but never followed it. I would rather each idea had an English equivalent on the screen. > regards > john I take it you applied the patch in some form? Or am I taking your feedback and finishing it myself? If I do a cvs update and you haven't done it right now, I'll finish it to your liking and resubmit the patch. Have fun, Darren