The patch attached sorts lables alphanumerically. This is nice uif you have a hundred of them and stick to the 'sec:*', 'eq:*' naming convention.
It's a new feature though. Ok to apply anyway? --- Related question: Would it be ok to change the functions vector<string> getLabelList() const into something like void fillLabelList(vector<string> &) const This would reduce the need to return dummy empty label lists in some cases and the code in buffer.C would be slightly simpler (i.e. instead of vector<string> getLabelList() const { vector<string> label_list; for (inset_iterator it = inset_const_iterator_begin(); it != inset_const_iterator_end(); ++it) { vector<string> const l = it->getLabelList(); label_list.insert(label_list.end(), l.begin(), l.end()); } return label_list; } we'd have void fillLabelList(vector<string> & label_list) const { for (inset_iterator it = inset_const_iterator_begin(); it != inset_const_iterator_end(); ++it) it->fillLabelList(label_list); } Andre' -- Those who desire to give up Freedom in order to gain Security, will not have, nor do they deserve, either one. (T. Jefferson)