John Levon wrote: > Can't we just do : > > freezeUndo() > { > if (++undo_frozen_count == 1) > undo_frozen = true; > } > > unfreezeUndo() > }{ > if (--undo_frozen_count == 0) > undo_frozen = false; > } >
IMO this counting is error prone. Anyway we could just put the whole stuff into a class with private static members (does this exist?) and instead of using the external bool use a function, but at the end IMO it's just the same. Jug -- -._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._ Dr. Jürgen Vigna E-Mail: [EMAIL PROTECTED] Mitterstrich 151/A Tel/Fax: +39-0471-450260 / +39-0471-450253 I-39050 Steinegg Web: http://www.lyx.org/~jug -._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._-._