As per Lars' request, here is a copy of the report:
--------------- Under powerpc-ibm-aix4.3.2.0 I get the followinf errors while compiling: /bin/sh ../../libtool --mode=compile g++ -DHAVE_CONFIG_H -I. -I. -I../../src -I./../ -I../.. -I../../boost -O -fno-rtti -fno-exceptions -c -o insetgraphics.lo `test -f insetgraphics.C || echo './'`insetgraphics.C g++ -DHAVE_CONFIG_H -I. -I. -I../../src -I./../ -I../.. -I../../boost -O -fno-rtti -fno-exceptions -c insetgraphics.C -Wp,-MD,.deps/insetgraphics.TPlo insetgraphics.C: In method `InsetGraphics::InsetGraphics()': insetgraphics.C:146: use of `unique_id' is ambiguous /usr/local/lib/gcc-lib/powerpc-ibm-aix4.3.1.0/2.95.2/include/sys/types.h:559: first declared as `struct unique_id' here insetgraphics.C:132: also declared as `const class string {anonymous}::unique_id()' here insetgraphics.C:146: use of `unique_id' is ambiguous /usr/local/lib/gcc-lib/powerpc-ibm-aix4.3.1.0/2.95.2/include/sys/types.h:559: first declared as `struct unique_id' here insetgraphics.C:132: also declared as `const class string {anonymous}::unique_id()' here insetgraphics.C: In method `InsetGraphics::InsetGraphics(const InsetGraphics &, const string &, bool = false)': insetgraphics.C:157: use of `unique_id' is ambiguous /usr/local/lib/gcc-lib/powerpc-ibm-aix4.3.1.0/2.95.2/include/sys/types.h:559: first declared as `struct unique_id' here insetgraphics.C:132: also declared as `const class string {anonymous}::unique_id()' here insetgraphics.C:157: use of `unique_id' is ambiguous /usr/local/lib/gcc-lib/powerpc-ibm-aix4.3.1.0/2.95.2/include/sys/types.h:559: first declared as `struct unique_id' here insetgraphics.C:132: also declared as `const class string {anonymous}::unique_id()' here make[3]: *** [insetgraphics.lo] Error 1 make[3]: Leaving directory `/users2/mhans/lyx-1.2.0/src/insets' make[2]: *** [all-recursive] Error 1 make[2]: Leaving directory `/users2/mhans/lyx-1.2.0/src' make[1]: *** [all] Error 2 make[1]: Leaving directory `/users2/mhans/lyx-1.2.0/src' make: *** [all-recursive] Error 1 Changing the name of unique_id() in insetgraphics.C and insetinclude.C fixes it, but I don't know if that is the good way to do it. ------------------ The question is to know whether there is better solution than renaming unique_id. JMarc