On Tue, Jun 05, 2001 at 12:23:08AM +0200, Lars Gullik Bj?nnes wrote:

> |     string const String(Buffer const *, bool label);
> | -   ///
> | -   string const String(Buffer const *, size_type beg, size_type end);
> | +   /// if withlabels is false, don't include label strings
> | +   string const String(Buffer const *, size_type beg, size_type end,
> | +           bool withlabels = true);
> 
> I like this even less.
> 
> default args should not be used as a flag to choose between two
> variants of a method. Instead it should be split into two methods.
> 
> String...
> StringWithLables...

would you prefer two methods with some duplicated code, or them to call
another internal function (StringInternal() ?)

thanks
john

p.s. I'm also doing String() and StringNoLabels() as it's simpler

-- 
"The English approach to ideas is not to kill them, but to let them die of neglect."
        - Jeremy Paxman 

Reply via email to