On Friday, 2 March 2018 19.14.52 WET Uwe Stöhr wrote: > - tfp = cmdOutput(interpreter + " -tt " + '"' > + tfp = cmdOutput('"' + interpreter + '"' + " -tt " + '"' > + os.path.join(srcdir, 'scripts', 'TeXFiles.py') + '"')
This is mater of style, but personally I think that the next option is more readable: tfp = cmdOutput('"%s" -tt "%s"' % (interpreter,os.path.join(srcdir, 'scripts', 'TeXFiles.py'))) In python this is called string interpolation and it uses to the famous C-printf notation. I want to stress that my comment is about readability as both versions do exactly the same thing. Regards, :-) -- José Abílio