I agree with Jurgen's previous judgement that this patch is actually
very simple. I do not think it can add any regressions and so think it
should go in, if people think it is really useful.
Minor comments below.
Richard
Index: development/FORMAT
===================================================================
--- development/FORMAT (revision 37448)
+++ development/FORMAT (working copy)
@@ -11,6 +11,11 @@
-----------------------
+2011-02-03 Edwin Leuven<e.leu...@gmail.com>
+ * Format incremented to 410 (r?)
+ Support tabular* : add tabularwidth parameter to
+ tabular features
+
Note that this should be 411, due to my forgetting to add 410 to this
file. (Thanks, Jurgen, for adding it.)
Index: src/insets/InsetTabular.cpp
===================================================================
--- src/insets/InsetTabular.cpp (revision 37448)
+++ src/insets/InsetTabular.cpp (working copy)
@@ -2616,7 +2621,10 @@
break;
}
} else {
- os<< "\\begin{tabular}";
+ if (tabular_width.zero())
I'd suggest something like:
bool const is_tabular_star = !tabular_width.zero();
and then use that below, mostly just for readability. We do this same
check about four times.
Richard