On Thu, Sep 04, 2008 at 09:36:45AM -0000, [EMAIL PROTECTED] wrote:
> @@ -68,6 +71,13 @@
>  {
>       all_formats_ = allFormats();
>  
> +     // Save the current selection if any
> +     Format const * current_format = 0;
> +     int const line = formatLW->currentRow();
> +     if (line >= 0 && line <= formatLW->count()
> +         && formatLW->selectedItems().size() > 0)
> +             current_format = all_formats_[line];

Are you sure that '<=' is better than '<' in this case?
If so, it might deserve a comment, '<=' looks rather unusual...

Andre'

Reply via email to