Lars Gullik Bjønnes wrote:
Abdelrazak Younes <[EMAIL PROTECTED]> writes:
| Modified: lyx-devel/trunk/src/insets/insettext.h
| URL:
| http://www.lyx.org/trac/file/lyx-devel/trunk/src/insets/insettext.h?rev=15779
| ==============================================================================
| --- lyx-devel/trunk/src/insets/insettext.h (original)
| +++ lyx-devel/trunk/src/insets/insettext.h Tue Nov 7 16:21:47 2006
| @@ -133,7 +133,9 @@
| ///
| InsetText(InsetText const &);
| ///
| - bool & Wide() const { return wide_inset_; }
| + bool Wide() const { return wide_inset_; }
| + ///
| + void setWide(bool wide_inset) { wide_inset_ = wide_inset; }
I saw that you already change Wide to wide. nice.
I think you should also change setWide to wide...
void wide(bool wide_inset) { wide_inset_ = wide_inset; }
either both setX and getX, or just X and X (I like this last one
best.)
Hum, yes I can see that both styles are used. I personally prefer to be
explicit when "setting" and implicit with "getting" a variable. This is
consistent with Qt coding style and I've followed pretty much that style
in the new frontend code.
Of course we could say that the style is different if the variable
underneath is a pointer to an object or a POD...
But at the end I guess that it would be better if we settle on one given
style. Let's make a poll! ;-)
Abdel.