Changes in directory llvm/lib/Target/PowerPC:
PPCISelLowering.cpp updated: 1.271 -> 1.272 --- Log message: Rename MVT::getVectorBaseType to MVT::getVectorElementType. --- Diffs of the changes: (+2 -2) PPCISelLowering.cpp | 4 ++-- 1 files changed, 2 insertions(+), 2 deletions(-) Index: llvm/lib/Target/PowerPC/PPCISelLowering.cpp diff -u llvm/lib/Target/PowerPC/PPCISelLowering.cpp:1.271 llvm/lib/Target/PowerPC/PPCISelLowering.cpp:1.272 --- llvm/lib/Target/PowerPC/PPCISelLowering.cpp:1.271 Fri May 18 18:21:46 2007 +++ llvm/lib/Target/PowerPC/PPCISelLowering.cpp Thu Jun 14 17:58:02 2007 @@ -2257,7 +2257,7 @@ MVT::ValueType CanonicalVT = VTys[SplatSize-1]; // Build a canonical splat for this value. - SDOperand Elt = DAG.getConstant(Val, MVT::getVectorBaseType(CanonicalVT)); + SDOperand Elt = DAG.getConstant(Val, MVT::getVectorElementType(CanonicalVT)); SmallVector<SDOperand, 8> Ops; Ops.assign(MVT::getVectorNumElements(CanonicalVT), Elt); SDOperand Res = DAG.getNode(ISD::BUILD_VECTOR, CanonicalVT, @@ -2647,7 +2647,7 @@ // The SHUFFLE_VECTOR mask is almost exactly what we want for vperm, except // that it is in input element units, not in bytes. Convert now. - MVT::ValueType EltVT = MVT::getVectorBaseType(V1.getValueType()); + MVT::ValueType EltVT = MVT::getVectorElementType(V1.getValueType()); unsigned BytesPerElement = MVT::getSizeInBits(EltVT)/8; SmallVector<SDOperand, 16> ResultMask; _______________________________________________ llvm-commits mailing list llvm-commits@cs.uiuc.edu http://lists.cs.uiuc.edu/mailman/listinfo/llvm-commits