Changes in directory llvm/lib/CodeGen:
IntrinsicLowering.cpp updated: 1.82 -> 1.83 --- Log message: Give names to the final result values of the part_set computations. This just aids in readability and debugability of the output. No functional change. --- Diffs of the changes: (+2 -2) IntrinsicLowering.cpp | 4 ++-- 1 files changed, 2 insertions(+), 2 deletions(-) Index: llvm/lib/CodeGen/IntrinsicLowering.cpp diff -u llvm/lib/CodeGen/IntrinsicLowering.cpp:1.82 llvm/lib/CodeGen/IntrinsicLowering.cpp:1.83 --- llvm/lib/CodeGen/IntrinsicLowering.cpp:1.82 Sat May 12 06:07:40 2007 +++ llvm/lib/CodeGen/IntrinsicLowering.cpp Mon May 14 12:21:17 2007 @@ -568,7 +568,7 @@ Value* nott2 = BinaryOperator::createXor(t2, ValMask, "", forward); Value* t3 = BinaryOperator::createShl(Rep4, Lo, "", forward); Value* t4 = BinaryOperator::createAnd(nott2, Val, "", forward); - Value* FRslt = BinaryOperator::createOr(t3, t4, "", forward); + Value* FRslt = BinaryOperator::createOr(t3, t4, "part_set_fwd", forward); new ReturnInst(FRslt, forward); // Block "reverse" @@ -587,7 +587,7 @@ Value* t11 = BinaryOperator::createSub(RepBitWidth, Hi, "", reverse); Value* t13 = BinaryOperator::createLShr(Rep4, t11, "",reverse); Value* t14 = BinaryOperator::createOr(t10, t9, "", reverse); - Value* RRslt = BinaryOperator::createOr(t14, t13, "", reverse); + Value* RRslt = BinaryOperator::createOr(t14, t13, "part_set_rvrs", reverse); new ReturnInst(RRslt, reverse); } _______________________________________________ llvm-commits mailing list llvm-commits@cs.uiuc.edu http://lists.cs.uiuc.edu/mailman/listinfo/llvm-commits